NEED HELP: Intake making truck shut off - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-08-2009, 04:41 PM Thread Starter
 
Seb_L's Avatar
 
Join Date: Oct 2008
Location: Ottawa, Ontario
Posts: 409
Intake making truck shut off

Just installed my ebay intake on my 08 Ranger, everything is tight, MAF is clean. All is good. Except when I give it gas just to accelerate, it bogs and shuts off. Fires right up after though. Did this 3 times. Then to test it I gave it a shot of gas. RPM would go up to 2k, then down to like 400 then back to idle. I just unplugged the batterie, will leave it like that for a few minutes then try it out.

Think anything else could be the problem?

If I dont figure it out by tonight I'm going back to stock, although I had to cut the MAF section of the stock airbox so I'll need to either glue it back up or keep stock piping but with after market intake.

2008 Ranger FX4
Some lift, some tires, and a winch
Seb_L is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-08-2009, 05:04 PM Thread Starter
 
Seb_L's Avatar
 
Join Date: Oct 2008
Location: Ottawa, Ontario
Posts: 409
Okay well after 10 mins of battery unplugged i tried it, same thing, but now with a CEL. going back to stock.

2008 Ranger FX4
Some lift, some tires, and a winch
Seb_L is offline  
post #3 of 4 (permalink) Old 04-08-2009, 05:31 PM Thread Starter
 
Seb_L's Avatar
 
Join Date: Oct 2008
Location: Ottawa, Ontario
Posts: 409
Everything is back to stock except the filter and everything is back to normal except CEL but that is nothing. While I was doing this I noticed the MAF still needed about 1 1/2 turns on one screw to be tight. So back in the rain to retry the intake piping.

2008 Ranger FX4
Some lift, some tires, and a winch
Seb_L is offline  
 
post #4 of 4 (permalink) Old 04-08-2009, 07:21 PM Thread Starter
 
Seb_L's Avatar
 
Join Date: Oct 2008
Location: Ottawa, Ontario
Posts: 409
End of story haha

I think the reason it was shutting off with all the piping was because my MAF had to be reversed to make it fit. So instead of A-B it was B-A. Might be the reason, might not. What I did was put the filter only, has a little growl but nothing insane. I'll get myself a K&N eventually lol

Exhaust SHOULD be on tomorrow morning so that is good news

2008 Ranger FX4
Some lift, some tires, and a winch
Seb_L is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 Intake Snepy Ranger Forum 4 01-14-2009 02:10 AM
Airaid Intake Matty Ranger Forum 7 04-07-2008 09:50 PM
Intake For 07 v6 stx STXPrincess Ranger Forum 6 03-16-2008 07:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome