strange miss...low grade misfire of TCC? - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-18-2008, 06:20 PM Thread Starter
Forum Newbie
 
Join Date: Feb 2008
Location: Merritt,BC
Posts: 2
strange miss...low grade misfire of TCC?

I have a 04 Screw w/ about 95000 kms (60000 miles...on the 5.4L, 3.73 unsure of the exact tranny, but 4spd/ w OD) and I am getting a strange miss/shudder. I seems to only happen when I am going downhill at about 110km/h @ 1800 rpm ish in cruise control. (obviously in OD) At first I thought I had gone over a big frost heave, but it happened again and the last trip. It accelerated just fine and if I keep my foot lightly on the gas it appears to go away. I did read a thread in the tranny section about the low grade misfire and replacing egr valve, COPS and plugs.... what I do not know is if it is more transmission or engine related..as it does "feel" like it is coming out of the rear end. Any ideas?

title should say OR TCC
dalman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Show us How Low did you go............. fordtough.ca Street Scene 39 03-01-2012 03:12 PM
Low Pricing for Lightning? Fordsy SVT Lightning 22 12-17-2008 11:05 PM
Strange noise from front end - opinions? 4X4 EH Truck/SUV Talk 3 08-20-2008 05:30 PM
low vacuum nnik Gas Engines 10 03-22-2008 11:52 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome