Tranny Slipping - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-26-2008, 06:46 PM Thread Starter
 
tohi2care's Avatar
 
Join Date: Jan 2008
Location: Maple Ridge, BC
Posts: 800
Tranny Slipping

I think my transmission is slipping. Last night I was comming home and I punched it and it felt as though the truck was losing power. Sometimes I break traction in the rain when I punch it but the roads were pretty dry. it only seemed to happen the one time so I'm thinking it has something to do with the truck not fully being warmed up. I also heard more than one time (as I kept trying to make it happen while trying to make the tranny slip again) a squeel which sounded like from under the hood on hard shifts. I think the squeel may be the belt slipping but I don't know. Any info from our resident Ford service techs will be appreciated.

The belt has never been changed and the tranny was serviced at 30k
2006 f150 xlt 4x4 5.4 Running Gryphon on lvl 2
tohi2care is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-26-2008, 07:06 PM
 
fordtough.ca's Avatar
 
Join Date: Feb 2007
Location: GTA
Posts: 7,721
fordtough.ca is offline  
post #3 of 5 (permalink) Old 10-27-2008, 01:52 AM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
Quote:
Originally Posted by tohi2care View Post
I think my transmission is slipping. Last night I was comming home and I punched it and it felt as though the truck was losing power. Sometimes I break traction in the rain when I punch it but the roads were pretty dry. it only seemed to happen the one time so I'm thinking it has something to do with the truck not fully being warmed up. I also heard more than one time (as I kept trying to make it happen while trying to make the tranny slip again) a squeel which sounded like from under the hood on hard shifts. I think the squeel may be the belt slipping but I don't know. Any info from our resident Ford service techs will be appreciated.

The belt has never been changed and the tranny was serviced at 30k
2006 f150 xlt 4x4 5.4 Running Gryphon on lvl 2
a belt chirp at wot is fairly normal,as for the "trans"concern did you have a check eng lamp or the wrench lamp or o/d lamp flashing?


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
 
post #4 of 5 (permalink) Old 10-27-2008, 10:06 PM Thread Starter
 
tohi2care's Avatar
 
Join Date: Jan 2008
Location: Maple Ridge, BC
Posts: 800
No I didn't but I think it may have been some ice or something because it hasn't happened again and I could not reproduce it even that night. I post again if it persists. Thanks for the belt info, as the maintanence manual says it only needs to be changed every 100,000kms and I was going to have it replaced.
tohi2care is offline  
post #5 of 5 (permalink) Old 10-28-2008, 12:22 AM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
no prob!nice truck by the way.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
tranny Q. rangerT Ranger Forum 14 10-11-2008 06:38 PM
Which Tranny rebelk Driveline and Transmission 3 08-12-2008 11:12 PM
Which Tranny Roadwarrior Driveline and Transmission 5 08-10-2008 04:34 AM
tranny 4x4.0 Driveline and Transmission 2 03-17-2008 07:44 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome