NEED HELP: Transmission problem - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-30-2010, 10:27 PM Thread Starter
Apprentice
 
Join Date: Jul 2009
Location: Edmonton Alberta
Posts: 8
Transmission problem

A few days ago I was driving home from work I noticed my truck was having troubles switching gears so when I got home I checked the fluid. It was a little low but nothing major. So I toped it off and went for a little drive then my tow haul would always start flashing on my dash. Then in a couple minutes my truck made a clunk sound and now I cant put it into any gears. I checked the fluid again and it does not smell burnt or look low. The only gear I have is park.

Most people I talked to say it sounds like an electrical problem. The truck is a 2006 automatic Superduty with 100k
quad_racer_12 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-03-2010, 02:49 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
if the tcil was flashing best place to start would be read trans codes.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #3 of 6 (permalink) Old 08-18-2010, 02:42 PM
 
Join Date: Jan 2009
Location: Powell River, BC
Posts: 135
so what was the outcome? popped snap ring? broken case?

05 F150 Lariat Screw.
89 LX5.0 usual mods.
ronburgundy is offline  
 
post #4 of 6 (permalink) Old 10-30-2010, 08:51 PM
Apprentice
 
Join Date: Jul 2010
Location: prince george bc canada
Posts: 5
I bet its the toque converter.
swampthing is offline  
post #5 of 6 (permalink) Old 05-17-2012, 07:05 PM
Forum Newbie
 
Join Date: May 2012
Location: Toronto
Posts: 2
you can't move the shift lever when the key is in the run position?
IgnitionDelay is offline  
post #6 of 6 (permalink) Old 05-17-2012, 07:21 PM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,740
Garage
OP hasn't signed on since July 31 2010...one day exactly after starting this thread.

I'm betting he's either solved the problem, or forgotten all about it. lol

801A - 6550 lb bundle of joy
SVT4MT is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission cooler line problem blueghost F-150 1997 to 2003 /04 Heritage Forum 5 06-29-2010 11:31 AM
What Transmission do you have? fordtough.ca Driveline and Transmission 34 04-04-2010 10:00 AM
Transmission shifting problem lilbruicer F-150 1997 to 2003 /04 Heritage Forum 6 11-12-2009 11:29 PM
Transmission problem lilbruicer F-150 1997 to 2003 /04 Heritage Forum 5 03-27-2009 03:03 PM
What Transmission? Disposable-Hero F-150 Pre-1997 Forum 5 01-22-2008 11:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome