1998 Ford F250 7.3 L Not Starting - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-19-2019, 10:08 AM
Derek.alex
Guest
 
Posts: n/a
1998 Ford F250 7.3 L Not Starting

Hi folks,

My son's F250 started intermittently failing with Battery Issues.
He changed both batteries and replaced the Alternator as it seemed to stop charging properly.

The other Symptom that he saw was Relay 3 was buzzing intermittently.
This is the top Right Relay in the Fuse box. We looked in the Ford Service Manual but it did not seem to be involved with the charging system in any way.

Now the truck will not start at all, the Engine will turn over, the Engine Start light doesn't come on at all.

I gave him an ODB II analyser to plug in, but it states " Failing to connect to PCM "

What would our next logical step be ?
 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-20-2019, 12:14 PM
Derek.alex
Guest
 
Posts: n/a
1998 Ford F250 7.3 L not starting

Hi folks,

Quick Update.
We pulled all Fuses, inspected them, then reinstalled one by one, validating that each one was good.
After doing this process the Wait to Start light suddenly came on during Key On Ignition.
So, looks like a bad connection at the Fuse Box.

Once the Engine was running, it appeared that the system was still not charging, in spite of replacing the batteries and Alternator.
Further testing revealed that Cables between Alternator and Battery Circuits were loose.
This was fixed and the Truck appears to be working well.
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome