NEED HELP: Engine Stall - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 01-02-2010, 03:39 PM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
Engine Stall

Just wondering if anyone can help me with my truck. As I was driving along, the engine started knocking, losing power and finally just stalled. I have a 2000 Excursion 7.3L, and as I'm not the original owner I automatically went to the fuel filter, because it sounded like it was starving for fuel. I changed the fuel filter and the truck still doesn't want to start. It cranks and tries to fire, but won't. Any suggestions?
oilman is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 01-02-2010, 03:58 PM
 
BIGPHIL's Avatar
 
Join Date: Feb 2009
Location: windsor
Posts: 479
not to shure the one to ask would be shelbyx1....... ( I.P.R pump) maby

You tried your best and you failed miserably. The lesson is 'never try'. -Homer Simpson
BIGPHIL is offline  
post #3 of 21 (permalink) Old 01-02-2010, 04:54 PM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
engine stall

I think the original problem was a dirty fuel filter. I've changed the filter and the truck won't start. It keeps cranking but won't start. Could it be a vapor lock? If so, how can I get the air out of the system?
oilman is offline  
 
post #4 of 21 (permalink) Old 01-02-2010, 06:41 PM
 
Phil G.'s Avatar
 
Join Date: Jun 2008
Location: Peterborough, ON
Posts: 529
If 7.3's are run dry they can be a bast... to get restarted. It's been while but if I recall there is a way of letting air out at the fuel filter on the engine. I can't remember if there is a plug, valve or it the cap has to be loosene dwhile you crank it over until you get all fuel and no air. Can postion sensors were am issue on the 7.3's as well but I don't know exactly what conditions to look for.
Phil G. is offline  
post #5 of 21 (permalink) Old 01-03-2010, 02:23 AM
 
Join Date: May 2008
Location: Oakville, ON
Posts: 234
When you crank the truck, does the tach register RPM??? If not, replace the CPS. Better yet, take it to FORD and have it replaced under the recall notice. Do you have access to an OBD scanner???

2001 F350 CC SWB 6spd....currently getting a complete 'makeover'. Stay tuned.
LOOSEWHEEL is offline  
post #6 of 21 (permalink) Old 01-03-2010, 02:26 AM
zip
 
zip's Avatar
 
Join Date: Aug 2008
Location: Princeton, BC
Posts: 367
My first thought was the CPS.

Chris

03 F350 Crew Cab 4x4 S/B Lariat,Procomp 2" leveling kit, zoodad mod, straight pipe
75 F150, 79 Bronco
zip is offline  
post #7 of 21 (permalink) Old 01-03-2010, 09:20 AM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
CPS was changed at my Ford Dealer under recall about a year or so ago.
oilman is offline  
post #8 of 21 (permalink) Old 01-03-2010, 09:24 AM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
Is there more than one fuel ilter on these trucks?
oilman is offline  
post #9 of 21 (permalink) Old 01-03-2010, 11:49 AM
 
Join Date: May 2008
Location: Oakville, ON
Posts: 234
Quote:
Originally Posted by oilman View Post
CPS was changed at my Ford Dealer under recall about a year or so ago.
Just because it was changed does not mean it will not fail. Double check to see if you register RPM when you crank.

When you 1st turn the key on, can you hear the fuel pump turn on?

Have you checked your oil level?

Only one fuel filter in the bowl on top.

2001 F350 CC SWB 6spd....currently getting a complete 'makeover'. Stay tuned.
LOOSEWHEEL is offline  
post #10 of 21 (permalink) Old 01-03-2010, 12:26 PM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
With the key in the on position, i listened underneath where the fuel pump is and could hear a buzzing noise, I assume that means the pump is working? Is that how the pump is supposed to sound or is it louder?
oilman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
4.6 -4.6 engine swap littlebronc Gas Engines 10 06-18-2009 11:09 AM
NEED HELP: 4.6 Engine Trouble Bruicer Gas Engines 2 02-07-2009 12:51 AM
NEED HELP: 5.4 Engine Missing SCrewFarmer Gas Engines 14 01-20-2009 08:44 PM
Ranger Engine? fordtough.ca Ranger Forum 13 03-16-2008 07:40 PM
engine code?? silverfox Gas Engines 7 09-12-2007 10:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome