Cluster - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 03-22-2008, 11:28 PM Thread Starter
 
Join Date: Mar 2008
Location: North Lancaster,On
Posts: 53
Question Cluster

Hi,

I'dlike to know if this have happened to someone. I have a cluster problemon my F150 XLT 99. The digital odometer sometimes light up, sometimes not. It occurs while running. It can be lighten up, then suddenly close. Do I have to change the entire cluster unit ??? Thanks.
blueghost is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 03-22-2008, 11:50 PM
 
Join Date: Jan 2008
Posts: 68
common problem. Happened to me too.

Not a big deal as it still counts the km, you just can't see it sometimes... but yes you would have to replace the whole cluster.
Frumpy is offline  
post #3 of 20 (permalink) Old 03-22-2008, 11:53 PM
 
f150phule's Avatar
 
Join Date: Mar 2007
Location: London, ON
Posts: 2,299
I think I saw on another forum ppl that had this issue,not sure if there is a fix for it other than replacing the cluster.


Whaddya mean I dont pay my bills?? Whydya think I'm broke!!

03 Lariat Crew 4x4 Line-x bedliner, Truxedo Lo-Pro QT Tonneau.
RIP [97 XL 4.2L V6]
f150phule is offline  
 
post #4 of 20 (permalink) Old 03-23-2008, 01:36 AM
 
SKRWZ's Avatar
 
Join Date: Nov 2007
Location: Burlington
Posts: 3,896
I have seen the repair for this somewhere and I cant remember where exactly at the moment but I belive the issue is a broken solder joint on the cluster if i find more info on this I will post it up for you

http://www.fordtough.ca/forums/signaturepics/sigpic435_3.gif
SKRWZ is offline  
post #5 of 20 (permalink) Old 03-23-2008, 01:41 AM
 
Coruptyed's Avatar
 
Join Date: Dec 2007
Location: Ontario
Posts: 846
Send a message via MSN to Coruptyed
ya this problem is very common, and skrwz is right there is a joint that is causeing the problem, thats how most have fixed theres.


The F150 UFO
Coruptyed is offline  
post #6 of 20 (permalink) Old 03-23-2008, 09:26 AM
 
alpine's Avatar
 
Join Date: Nov 2007
Location: Stoney Creek, Ontario
Posts: 198
Do not replace the cluster, there is an easy repair if you can get the cluster out and you have a soldering iron.
This is the site with the instructions(with pictures):

http://www.f150online.com/forums/sho...light=odometer
alpine is offline  
post #7 of 20 (permalink) Old 03-23-2008, 10:12 AM Thread Starter
 
Join Date: Mar 2008
Location: North Lancaster,On
Posts: 53
Thanks all for answering so fast.

I planned to remove the cluster today to do a check... Will get the soldering iron out too :-)
blueghost is offline  
post #8 of 20 (permalink) Old 03-23-2008, 11:26 AM
 
Bush_aholic's Avatar
 
Join Date: Dec 2007
Location: Elliot Lake, Ontario
Posts: 2,108
Send a message via MSN to Bush_aholic
well I have this probleme too, rarely happends I just tap the cluster and it lights back up rite away.....just started and my dash was taken apart not that long ago must have roughed up the connection


I only drive in the city, to get out of it!!!
Bush_aholic is offline  
post #9 of 20 (permalink) Old 03-23-2008, 02:31 PM Thread Starter
 
Join Date: Mar 2008
Location: North Lancaster,On
Posts: 53
Cool

Cluster is removed and all goes well. Didn't take a lot of time.
However, soldering iron is out and magnifying glass is not very good

Will wait tomorrow and get another one at Canadian tire...

Hope re-connnecting it will be that easy lolll.

Thanks all for your help, it was really appreciated
blueghost is offline  
post #10 of 20 (permalink) Old 03-27-2008, 10:12 PM
 
sledmanjones's Avatar
 
Join Date: Mar 2008
Location: Snow Lake Manitoba
Posts: 50
I did this on my 99 and it was very easy.Just get the soldering iron hot and heat each pad on the odometer until it liquefies,if there is very little solder and you feel you need to add some,get solder for electronics,not for pipes, but it works great,and doesn't cost much more than your time to do it.
sledmanjones is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge cluster swap on a 97-98 F150 with analog odometers f150phule Sticky Tech/How to Section 2 10-20-2008 02:09 AM
Installed new gauge cluster w/Tach f150phule Interior 9 10-19-2008 07:51 PM
Instrument Cluster / Gauges Upgrade fordtough.ca Interior 4 03-29-2008 07:06 PM
Roush Performance Series Instrument Cluster fordtough.ca Interior 19 02-20-2008 10:47 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome