Heater problem - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 01-07-2009, 12:59 PM Thread Starter
Apprentice
 
Join Date: Jan 2009
Location: Sydney,Nova Scotia
Posts: 6
Heater problem

My Truck developed a problem with the heater today,it will not blow heat unless the switch is on the High Setting.Has anyone else had this problem?
the truck is a 03 F150 with A/C.
Any help would be great.
thanks
RedFlareside4X4 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 01-07-2009, 01:13 PM
 
SKRWZ's Avatar
 
Join Date: Nov 2007
Location: Burlington
Posts: 3,896
Do you have the dial heater control knobs on it?.... if you do pull the one off that goes from hot to could and look at the back side of it they were prone to crack and break


BTW welcome to fordtough.ca

http://www.fordtough.ca/forums/signaturepics/sigpic435_3.gif
SKRWZ is offline  
post #3 of 15 (permalink) Old 01-07-2009, 01:36 PM Thread Starter
Apprentice
 
Join Date: Jan 2009
Location: Sydney,Nova Scotia
Posts: 6
Quote:
Originally Posted by SKRWZ View Post
Do you have the dial heater control knobs on it?.... if you do pull the one off that goes from hot to could and look at the back side of it they were prone to crack and break


BTW welcome to fordtough.ca
mine has 3 knobs ...one controls hot and cold air,one is for A/C and heater ,the other one has 4 Fan setting's from lo to Hi.i can feel the knob clicking on each setting but the heater only blows hot air on the Hi setting.but i will pull the knob off and check it out.
Thanks
RedFlareside4X4 is offline  
 
post #4 of 15 (permalink) Old 01-07-2009, 04:02 PM
 
Fordwheeler's Avatar
 
Join Date: Aug 2008
Location: Calgary Alberta
Posts: 1,054
I had the same problem in my 99 350 and it was the resistor, cheap fix.

1997 F-150 xl
1984 Honda XR200R (the toy)
2007 Honda CRF100f (the spare toy)
2005 Jayco Baja 10Y (the home away from home)
Fordwheeler is offline  
post #5 of 15 (permalink) Old 01-07-2009, 04:46 PM
 
SKRWZ's Avatar
 
Join Date: Nov 2007
Location: Burlington
Posts: 3,896
sorry I must have read this post wrong like Fordwheeler said it does sound like the resistor

http://www.fordtough.ca/forums/signaturepics/sigpic435_3.gif
SKRWZ is offline  
post #6 of 15 (permalink) Old 01-07-2009, 08:49 PM
 
Oreo's Avatar
 
Join Date: Mar 2008
Location: Mississauga, Ont
Posts: 477
I had the same problem, I didn't have low and medium for a while then I lost high. It's in the engine bay.

!!#4979, Kansas City April 12 2001!!


Pictures
Oreo is offline  
post #7 of 15 (permalink) Old 01-08-2009, 07:21 AM Thread Starter
Apprentice
 
Join Date: Jan 2009
Location: Sydney,Nova Scotia
Posts: 6
what was wrong in the engine Bay?
RedFlareside4X4 is offline  
post #8 of 15 (permalink) Old 01-08-2009, 11:59 AM
 
Fordwheeler's Avatar
 
Join Date: Aug 2008
Location: Calgary Alberta
Posts: 1,054
I think Oreo meant that the resistor is in the engine bay?

1997 F-150 xl
1984 Honda XR200R (the toy)
2007 Honda CRF100f (the spare toy)
2005 Jayco Baja 10Y (the home away from home)
Fordwheeler is offline  
post #9 of 15 (permalink) Old 01-08-2009, 12:08 PM
 
SKRWZ's Avatar
 
Join Date: Nov 2007
Location: Burlington
Posts: 3,896
It's located inside the on the passenger side under the glove compartment. Also the blower motor is the same type for all F150 from 1997 to 2003. You will see a plug with some wires on it. Thats the resistor remove the two screws (7mm I belive) that secure to the heater box and remove it




http://www.fordtough.ca/forums/signaturepics/sigpic435_3.gif
SKRWZ is offline  
post #10 of 15 (permalink) Old 01-08-2009, 04:08 PM
 
Fordwheeler's Avatar
 
Join Date: Aug 2008
Location: Calgary Alberta
Posts: 1,054
Yup thats it, but mine (99 350) is under the hood.

1997 F-150 xl
1984 Honda XR200R (the toy)
2007 Honda CRF100f (the spare toy)
2005 Jayco Baja 10Y (the home away from home)
Fordwheeler is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP: Musty-smelling heater Gord Interior 12 01-03-2013 12:31 PM
NEED HELP: 2004 F150 Heater Problem BigDawg99 Interior 11 12-19-2009 07:38 AM
NEED HELP: Oil Pan Heater tedder57 F-150 2004 to 2008 Forum 3 11-23-2008 08:24 AM
Heater Help BigDawg99 Interior 8 11-08-2008 07:17 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome