NEED HELP: Need Help Troubleshooting a few things! - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 48 (permalink) Old 04-06-2009, 09:18 PM Thread Starter
 
Join Date: Feb 2009
Posts: 37
Need Help Troubleshooting a few things!

So I just recently bought my first truck, its a 1990 F150 and I'd really like to have it ready for the inspection in 2 weeks. This means I definitely have a few things that need to get done in that time frame.

1. My horn doesn't work. When you hit the button a clicking noise is heard on the passenger side. I've checked the fuse under the steering column and its still good. What next? Is there another fuse box that I've missed?

2. Turn signal doesn't stick up. It sticks down but to make a right turn holding the lever up will be necessary. I don't think that that will go over too well during the inspection.

3.Tail Lights don't really work. The drivers side brake light will sometimes come on, but its very very dim. A few people have suggested checking grounds. How do I get them off so I can check?

Sorry for the extremely amatuer questions haha. But its my first truck/project and I'm really new to working on vehicles. I hope someone will be able to help a brotha out. lol

Thanks,
Tyler
etniesbmx1 is offline  
Sponsored Links
Advertisement
 
post #2 of 48 (permalink) Old 04-06-2009, 10:36 PM
 
taisa899's Avatar
 
Join Date: Feb 2007
Location: Amherstburg, Ontario
Posts: 4,934
Send a message via MSN to taisa899
first replace all the bulbs. Second is a question. Do you have a multimeter?



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Nitrous is like a beautiful girl with an STD. You know you want to hit it but you're afraid of the consequences
taisa899 is offline  
post #3 of 48 (permalink) Old 04-07-2009, 12:08 AM Thread Starter
 
Join Date: Feb 2009
Posts: 37
Buying new bulbs tomorrow!

And no I don't unfortunately

*EDIT*

I figure this would be the best place to ask, rather then making another thread, but I'm having trouble finding any aftermarket parts for my 90. Anyone have any good recommendations as too where to look.
etniesbmx1 is offline  
 
post #4 of 48 (permalink) Old 04-07-2009, 12:13 AM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
if you hear a click when horn is pushed your relay is working the next thing to check would be the horn itself,just check if you have power when pressed,the signal not holding oneway can be the steering wheel is off center(need alignment)or the spring is broken in the multifunction switch,as for your lighting woes the grounds will be on the frame at rear driversside to remove the taillamps open the tailgate and there will be two 8mm head bolts remove bolts and pull outwards on lamp assm also check for broken/coroded wires at the connector at back of frame on drivers side.hope this helps


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #5 of 48 (permalink) Old 04-07-2009, 12:25 AM
 
taisa899's Avatar
 
Join Date: Feb 2007
Location: Amherstburg, Ontario
Posts: 4,934
Send a message via MSN to taisa899
taisa899 is offline  
post #6 of 48 (permalink) Old 04-07-2009, 01:08 AM Thread Starter
 
Join Date: Feb 2009
Posts: 37
shelbyx1- thank you! very informative post! haha I'll check it out tomorrow.

taisa899- Pretty much anything. I'm having a hard time finding anything to do with the interior and body parts (grill, bumpers, etc). And as for the engine, google didn't help me much. haha

Thanks guys,
Tyler
etniesbmx1 is offline  
post #7 of 48 (permalink) Old 04-07-2009, 01:13 AM
 
taisa899's Avatar
 
Join Date: Feb 2007
Location: Amherstburg, Ontario
Posts: 4,934
Send a message via MSN to taisa899
for engine check out my profile. For body it depends on what you are looking for



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
taisa899 is offline  
post #8 of 48 (permalink) Old 04-07-2009, 01:24 AM Thread Starter
 
Join Date: Feb 2009
Posts: 37
Did exactly that, and all it said was 5.0HO, maybe I'm looking in the wrong place? haha damn noobs eh.
etniesbmx1 is offline  
post #9 of 48 (permalink) Old 04-07-2009, 02:14 AM
 
taisa899's Avatar
 
Join Date: Feb 2007
Location: Amherstburg, Ontario
Posts: 4,934
Send a message via MSN to taisa899
taisa899 is offline  
post #10 of 48 (permalink) Old 04-07-2009, 02:21 AM
 
taisa899's Avatar
 
Join Date: Feb 2007
Location: Amherstburg, Ontario
Posts: 4,934
Send a message via MSN to taisa899
hang in there seems to be a problem with my profile. Let me check with Dave



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
taisa899 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome