NEED HELP: 2.3l idle problem/ oil sending unit - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Ranger Forum ALL YEARS ALL MODELS

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-02-2011, 04:51 PM Thread Starter
Forum Newbie
 
Join Date: Oct 2011
Location: saskatoon, sk
Posts: 3
2.3l idle problem/ oil sending unit

hello. I've got an '89 ranger with a 2.3l distributorless ignition system. The truck will be running fine then, when I come to a stop, the engine will rev up and won't idle down even if I push the gas pedal. It doesn't do this all the time but it does do it a lot. I'd say about 70% of the time. I've heard that a faulty iac valve can stick and cause this problem. I checked my hayne's manual and it doesn't even mention an iac valve. So, I'm not sure what the problem can be. If anyone can give me some advice, I'd greatly appreciate it.

Also, does anyone know where the oil sending unit is. My oil guage needle works on and off and so I think the o.s.unit needs replacing. thanks in advance.
watermellon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-03-2011, 07:37 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,530
Garage
Haynes may call it an idle air by-pass valve but it's located on the throttle body and the oil pressure sender is located on the left rear side of the cylinder head, probably down behind the egr unit. Check your engine to cab/chassis ground wire first though. That might be the cause of both problems.

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #3 of 3 (permalink) Old 10-04-2011, 06:08 AM
 
Maritime Storm's Avatar
 
Join Date: Jun 2009
Location: Riverview, NB, Canada
Posts: 122
Sounds like to me that either or throttle is sticky occasionally or the IAC is due for a good cleaning. I would clean the throttle body and IAC before considering digging any further into it, replace the gaskets don't re-use them.

2009 Ranger Sport 2WD 4.0L/3.55:1/5spd Bone Stock.
Maritime Storm is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
idle/RPM lonerangerxlt F-150 2004 to 2008 Forum 5 02-15-2010 11:45 PM
Idle Problem countryboy Gas Engines 10 01-20-2010 01:31 AM
NEED HELP: Temperture sending unit Blacktopper Sticky Tech/How to Section 2 11-03-2009 06:02 PM
NEED HELP: high idle CKM Ranger Forum 8 12-08-2008 11:31 PM
Changed oil pressure sending unit today Larry227 F-150 1997 to 2003 /04 Heritage Forum 1 09-14-2008 05:10 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome