NEED HELP: Cold start problem - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Ranger Forum ALL YEARS ALL MODELS

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-25-2019, 09:21 AM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
Cold start problem

Hi guys. It's been quite a while since I've visited here.
I have an annoying problem I can't track down. 3L, 2007 Ranger. Just turned 100K. When the temps dip below 0 C, the engine will crank but won't start. I found out, by accident, if I cycle the key on and off several times, it fires right up and it's fine until parked for several hours below 0 again. The first time it happened, I suspected the fuel pump and cycled the key on and off, listening for the pump. Then it started. The check engine light is not coming on and there are no error codes recorded.

I don't have the time to try and track this down myself so I took it to my mechanic. He checked the fuel pressure (it's fine), replaced the fuel filter and replaced the hi idle motor (a guess). It was fine until the next morning when it wouldn't start again. He suggested replacing the coil and wires (original). I have a spare coil pack so that's the plan right now.

It's possible there's a hairline crack in the coil that's breaking contact when cold, but the lack of error code has us both questioning that.

Anyone have any suggestion what else we could look at?
Cheers
J.P.
J.P. (Mount hope) is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-25-2019, 04:45 PM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,528
Garage
Entirely possible. I had a Mercedes that would do the exact opposite. When the car warmed up the coil would over heat and kill the engine. New expensive coil solved that.

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #3 of 10 (permalink) Old 01-25-2019, 08:50 PM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
Thanks for the reply.
That actually makes more sense. Everything expands when it heats up. Ive had similar problems with other vehicles in the past.
Unfortunately, it was -7 today and she fired up without issue every time. Unfortunate because if it's not acting up, it's that much harder to track down.
One other symptom that may or may not be related. Two or three times over the past year, I'd be cruising along and the engine would just cut out for about a second then would be fine for months.

It goes in next week to get the coil and wires changed out. I guess I'll see what happens after that.

J.P.
J.P. (Mount hope) is offline  
 
post #4 of 10 (permalink) Old 01-26-2019, 06:41 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,528
Garage
Another thought just came to mind. Have you checked the oil for gasoline content? Another thought is intermittent ignition switch or a relay could have dirty contacts. From what you're describing, I would check some relays first.

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #5 of 10 (permalink) Old 01-26-2019, 09:36 AM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
All good suggestions. I guess the cold is just as likely to effect a relay as anything else. I hadn't considered that.
I'll have them replace any relays that might prevent it from starting. If that's not the problem, I'll have spares. Cheep enough to try.
Thanks
J.P. (Mount hope) is offline  
post #6 of 10 (permalink) Old 01-30-2019, 09:38 AM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
No resolution yet.
Last week the no start became random. Hot or cold didn't matter. For the last few days it would start fine when cold...and it's been pretty cold, but then it was giving me trouble when it was warm. Strange.
I dropped it off with my mechanic this morning. He's going to replace the coil and plug wires as well as any relays associated with the engine starting/running. Hopefully that will take care of it.
I'll update this thread with the results as soon as I have more info.
Cheers
J.P.
J.P. (Mount hope) is offline  
post #7 of 10 (permalink) Old 01-31-2019, 06:37 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,528
Garage
One last thought is the roll over switch, if it has one.

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #8 of 10 (permalink) Old 01-31-2019, 02:58 PM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
Just got the truck back. This time when they put it on the scanner, three codes showed up. All three indicated the ECU needed to be re-flashed and updated. All three problems related to intermittent no starts. No parts were changed. We'll see how things go from here.
Nice thing is he didn't charge me labour for replacing the fuel filter or the high idle motor.
Cheers. Thanks for the help.
J.P.
J.P. (Mount hope) is offline  
post #9 of 10 (permalink) Old 02-15-2019, 09:35 PM Thread Starter
 
J.P. (Mount hope)'s Avatar
 
Join Date: Oct 2008
Location: Mount Hope Ont.
Posts: 50
Just wanted to update. It would seem the updates did the trick. No problems since.
Cheers
J.P. (Mount hope) is offline  
post #10 of 10 (permalink) Old 02-16-2019, 05:57 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,528
Garage
You're Welcome!

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP: Whining noise on cold start up Chuck P Gas Engines 32 12-17-2009 11:15 PM
Remote start won't start MrSen F-150 2004 to 2008 Forum 8 12-04-2009 07:58 PM
Ranger cold start brauner_1 Gas Engines 9 12-21-2008 10:31 PM
99 Ranger - Cold Start, Low Oil Pressure 00PowderSpecial Ranger Forum 5 12-19-2008 12:10 PM
98 f150 ext cab 4x4 cold air intake problem..help duece F-150 1997 to 2003 /04 Heritage Forum 6 03-03-2008 10:24 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome