A Couple of Observations About my Ranger - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Ranger Forum ALL YEARS ALL MODELS

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 07-14-2008, 10:46 AM Thread Starter
 
Join Date: Jun 2008
Location: near Barrie
Posts: 19
A Couple of Observations About my Ranger

I noticed that there is no splash guard (plastic inner fender insert) on my truck. I was looking in the wheel wheel - front driver's side fender - and could see the steering box and assorted other items in the engine compartment. All were completely exposed.

I phoned the dealership and asked about this. There are bolt holes but no guard in place. The service manager said that they stopped putting them in two or three years ago. Something about power steering cooling. Weird.

The other thing is that, on the XL model, there are no mud flaps. The wife commented that you could really hear the stones bouncing around in the wheel well.

Two "spinny" comments!
Steve is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 07-14-2008, 07:16 PM
 
fordtough.ca's Avatar
 
Join Date: Feb 2007
Location: GTA
Posts: 7,721
One way to fix the stones noise is to get it sprayed using sound or rust proofed compound
I don't know if thats what you are looking for but is an suggestion



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
fordtough.ca is offline  
post #3 of 15 (permalink) Old 07-14-2008, 07:33 PM
 
CanadianRanger's Avatar
 
Join Date: Mar 2008
Location: Saint John, NB
Posts: 1,901
Garage
Steve, I have an 08 Sport. Your post made me go look. The front has a liner from the front of wheel to back, but it is open around the shock and I can see the motor. The rear has some sort of inner rear splash guard, behind and above the rear wheels. And rear mudflaps only.

2014 F150 FX4 | SuperCrew | 5.0L | 4x4 | Sterling Grey Metallic
CanadianRanger is offline  
 
post #4 of 15 (permalink) Old 07-14-2008, 07:48 PM
 
Cooker's Avatar
 
Join Date: May 2008
Location: Abbotsford, BC
Posts: 240
I have an 08 FX4 and mine has a rubber type flap on the driver side inner wheel well covering the motor.

2009 F150 XLT 4X4 5.4 / 2" Autospring Lift / 275/65R20 BFG All Terrains (34.1)
Cooker is offline  
post #5 of 15 (permalink) Old 07-15-2008, 12:40 AM
 
mitchbtu's Avatar
 
Join Date: May 2008
Location: Surrey BC
Posts: 370
Send a message via MSN to mitchbtu
Steve that sounds a bit weird to me, I would phone another dealership and get a 2nd opinion.... I would think that the wheelwell area being exposed would promote more rusty parts in the engine compartment....

99 Ford Ranger X-Cab 4x4. 3L V6. 5 Spd.. Mods -Michelin 31x10.5x15 XRadial Tires, Proformance Venom II Chip, Cold Air Intake, Window Visors, Euro Marker and Tail Lights, LED Front Corners, 05 Ranger Side Mirrors, 6000k HID Headlamps, Stock Cass/CD Stereo(taken from a Windstar), Interior Dome/Map(taken from a Taurus), White/Blue Glow Instruments, Stainless Steel Bezel...
mitchbtu is offline  
post #6 of 15 (permalink) Old 07-15-2008, 04:16 PM
 
redbull2008's Avatar
 
Join Date: Dec 2007
Location: Schreiber,Ontario Canada
Posts: 37
i've got an 08 ranger and it doesn't have a piece in the wheel well area, My uncle told me his 02 mazda B3000 had that piece but his 08 doesn't.
redbull2008 is offline  
post #7 of 15 (permalink) Old 07-15-2008, 07:03 PM
 
RuggedRanger15's Avatar
 
Join Date: Jun 2008
Location: Port Coquitlam
Posts: 389
Send a message via MSN to RuggedRanger15
maybe its just an xl thing


2008 Ranger Sport 4x4|Grey|5-spd stick|4.0 SOHC|35"x12.5" BFG KM2s|15" Daytona Rock Crawlers 15x10's|K&N CAI|Magnaflow Catback|Truxx AAL's|3" PA Body Lift|Custom Bumper|Custom Tow Hooks|Bilstein 5100's
RuggedRanger15 is offline  
post #8 of 15 (permalink) Old 07-16-2008, 10:37 PM Thread Starter
 
Join Date: Jun 2008
Location: near Barrie
Posts: 19
JC Whitney and some other places have that splash guard listed. 2008 Ranger front left fender. I don't get it either. For $25 US, I'll buy one. :icon_sad:

I had to tighten my antenna. :icon_sad:

The rear mud flaps don't have a place on which to attach. The fender has no frame or area where you can mount one, like there was on my 2000. Another aftermarket thing. :icon_sad:

Today I noticed that the a/c seems to be on when I select 'vents and floor'. It should be outside air coming in I thought. A/C cool, instead of muggy and warm. Does anyone else have this?

Lest anyone think I'm being picky, these are things that are different from my 2000.
Steve is offline  
post #9 of 15 (permalink) Old 07-16-2008, 11:04 PM
 
CanadianRanger's Avatar
 
Join Date: Mar 2008
Location: Saint John, NB
Posts: 1,901
Garage
Steve, there are brackets (basically 1/4" rod) that hold the rear mudflaps in place.

2014 F150 FX4 | SuperCrew | 5.0L | 4x4 | Sterling Grey Metallic
CanadianRanger is offline  
post #10 of 15 (permalink) Old 07-17-2008, 12:30 AM
 
mitchbtu's Avatar
 
Join Date: May 2008
Location: Surrey BC
Posts: 370
Send a message via MSN to mitchbtu
The AC is also used to dry the air before its sent into the passenger compartment, this may be why its coming on the way it does...

99 Ford Ranger X-Cab 4x4. 3L V6. 5 Spd.. Mods -Michelin 31x10.5x15 XRadial Tires, Proformance Venom II Chip, Cold Air Intake, Window Visors, Euro Marker and Tail Lights, LED Front Corners, 05 Ranger Side Mirrors, 6000k HID Headlamps, Stock Cass/CD Stereo(taken from a Windstar), Interior Dome/Map(taken from a Taurus), White/Blue Glow Instruments, Stainless Steel Bezel...
mitchbtu is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple new shots RuggedRanger15 Ranger Forum 21 06-07-2009 05:25 PM
Couple questions Fordwheeler Super Duty Forum 18 10-12-2008 12:08 PM
couple new pics RuggedRanger15 Ranger Forum 12 10-08-2008 03:34 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome