Wipers Stopped Working - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
F-150 2004 to 2008 Forum XL, XLT, STX, LARIAT, FX4, FX2

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 04-11-2011, 01:25 PM Thread Starter
 
herbz's Avatar
 
Join Date: Dec 2007
Location: Cochrane, Alberta
Posts: 1,114
Send a message via MSN to herbz
Wipers Stopped Working

My wipers seemed to be getting slower and slower and now today I tried to give them a quick swipe and they crawled up the window and stopped right at the peak of the swipe. They slowly made their way back down at the end of the cycle. Does it sound like the motor or linkage?

2016 F150 XLT XTR 4x4 2.7 Ecoboost
herbz is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-11-2011, 01:39 PM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
gears?
wiper arm gear stripped?
slow symptoms sound like motor tho.

see if you can remove the cowl to see if you can see the wiper linkage move. ?
Viper238 is offline  
post #3 of 9 (permalink) Old 04-11-2011, 09:46 PM
 
prairiethunder's Avatar
 
Join Date: Mar 2011
Location: Eatonia, Saskatchewan
Posts: 192
I would say the motor gave out on you. Lift up the cowl and take a look.

prairiethunder
2007 F-150 FX4
2007 F-150 King Ranch
1989 F-150 XLT
1949 F-1
prairiethunder is offline  
 
post #4 of 9 (permalink) Old 04-12-2011, 12:12 AM Thread Starter
 
herbz's Avatar
 
Join Date: Dec 2007
Location: Cochrane, Alberta
Posts: 1,114
Send a message via MSN to herbz
Definitely thinking the motor is gone/going. Although my girlfriends car had the same symptoms and it turned out just to be some corrosion on the linkage slowing things down. I'm hoping to get in there and have a look tomorrow. I got a quick price on a new motor today. $138 core charge to exchange it for a new one from Ford.

2016 F150 XLT XTR 4x4 2.7 Ecoboost
herbz is offline  
post #5 of 9 (permalink) Old 04-12-2011, 12:18 AM
 
prairiethunder's Avatar
 
Join Date: Mar 2011
Location: Eatonia, Saskatchewan
Posts: 192
That sounds about right. Might be able to check with NAPA and get one a little cheaper, but I have found NAPA parts we use on the farm vehicles have lost quality lately.

prairiethunder
2007 F-150 FX4
2007 F-150 King Ranch
1989 F-150 XLT
1949 F-1
prairiethunder is offline  
post #6 of 9 (permalink) Old 04-14-2011, 11:33 AM Thread Starter
 
herbz's Avatar
 
Join Date: Dec 2007
Location: Cochrane, Alberta
Posts: 1,114
Send a message via MSN to herbz
It turned out to be a little corrosion on the linkage stopping it from doing its see-saw like action. I cleaned it up and they work perfectly fine now at all speeds.

2016 F150 XLT XTR 4x4 2.7 Ecoboost
herbz is offline  
post #7 of 9 (permalink) Old 04-14-2011, 07:13 PM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,741
Garage
Good info to pass along...glad to hear it wasn't all that serious. Gotta love the easy, inexpensive fixes!!!

801A - 6550 lb bundle of joy
SVT4MT is offline  
post #8 of 9 (permalink) Old 04-14-2011, 11:22 PM Thread Starter
 
herbz's Avatar
 
Join Date: Dec 2007
Location: Cochrane, Alberta
Posts: 1,114
Send a message via MSN to herbz
Quote:
Originally Posted by GT4MT View Post
Good info to pass along...glad to hear it wasn't all that serious. Gotta love the easy, inexpensive fixes!!!
I just had a hunch seeing as it happened on my gf's car and it turned out to be the exact same thing.

2016 F150 XLT XTR 4x4 2.7 Ecoboost
herbz is offline  
post #9 of 9 (permalink) Old 04-15-2011, 01:46 PM
 
prairiethunder's Avatar
 
Join Date: Mar 2011
Location: Eatonia, Saskatchewan
Posts: 192
Good to get these little ideas. This site is full of em!

prairiethunder
2007 F-150 FX4
2007 F-150 King Ranch
1989 F-150 XLT
1949 F-1
prairiethunder is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP: windshield wipers Slasher Exterior 8 07-13-2009 08:47 PM
'02 f350 wipers and washer no worky Loadedagain Super Duty Forum 17 04-15-2009 08:34 PM
Cruise not working Bruicer F-150 1997 to 2003 /04 Heritage Forum 1 02-13-2009 10:47 PM
Opinions wanted for Wipers Matty Ranger Forum 19 01-19-2009 09:29 AM
My Factory Air Suspension stopped working? MRGADGET Wheels and Tires 2 05-12-2008 11:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome