radio, lock problem - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
F-150 2004 to 2008 Forum XL, XLT, STX, LARIAT, FX4, FX2

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 11-16-2013, 06:54 PM Thread Starter
 
macs07's Avatar
 
Join Date: Oct 2008
Location: Toronto
Posts: 113
radio, lock problem

This is an 07 FX2 S/crew stock other than an Edge.
Normally when the ignition is turned off the radio will stay on for 10 minutes or untill the d/door is opened. Now the radio will stay on with the ignition off, door opened, closed and locked with the key fob. I have to turn it off manually.
The d/door power d/lock switch is not working. When the vehicle is put into park the d/s and p/s doors unlock but not the rear doors. All the locks work properly with the key fob or the touch pad. The p/side door lock switch works fine as well.
Any ideas???
macs07 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 11-16-2013, 09:34 PM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Sounds like it might be the drivers door pin?



Sent from my iPhone using Tapatalk
Viper238 is offline  
post #3 of 13 (permalink) Old 11-16-2013, 10:09 PM Thread Starter
 
macs07's Avatar
 
Join Date: Oct 2008
Location: Toronto
Posts: 113
Quote:
Originally Posted by Viper238 View Post
Sounds like it might be the drivers door pin?



Sent from my iPhone using Tapatalk
Is there a way I check to confirm, don't know where to locate the drivers door pin.
macs07 is offline  
 
post #4 of 13 (permalink) Old 11-16-2013, 10:47 PM
 
TRNRBILT's Avatar
 
Join Date: Dec 2012
Location: Kilbride,Ontario
Posts: 362
Not sure about the 07s but on the newer 09 up style the door pin is located inside the hinge. Unlike the old vehicles were it was just a pin that got pushed in and out. Travis may chime in on weather or not it is the same setup though because I am not 100% sure.

If the mud ain't flyin' ... You ain't tryin'

2009 F-150 XLT 4x4 4.6L 2" Ready lift front and rear
1989 Bronco II 4x4 2.9L 6 - 8" skyjacker lift front and rear
1987/89 Bronco II 4x4 work in progress. Full size Dana 44,Ford 8.8 5.0L swap coming
TRNRBILT is offline  
post #5 of 13 (permalink) Old 11-17-2013, 05:23 AM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Quick search lead me to this.
Some quys are saying its in the wiring for the door pin. Either in the sil or door jam boot. Purple wire.

http://www.f150forum.com/f4/need-hel...urn-off-96414/


Sent from my iPhone using Tapatalk
Viper238 is offline  
post #6 of 13 (permalink) Old 11-18-2013, 05:17 PM Thread Starter
 
macs07's Avatar
 
Join Date: Oct 2008
Location: Toronto
Posts: 113
Quote:
Originally Posted by macs07 View Post
This is an 07 FX2 S/crew stock other than an Edge.
Normally when the ignition is turned off the radio will stay on for 10 minutes or untill the d/door is opened. Now the radio will stay on with the ignition off, door opened, closed and locked with the key fob. I have to turn it off manually.
The d/door power d/lock switch is not working. When the vehicle is put into park the d/s and p/s doors unlock but not the rear doors. All the locks work properly with the key fob or the touch pad. The p/side door lock switch works fine as well.
Any ideas???
Well little more info on the radio lock issue, the only thing that works on the drivers door is the door handle, no windows, mirrors, locks, exterior key pad, no interior lights.
The window up/down does not work on ANY other door. The radio, interior lights will work off the P/door control, but not the locks or windows.
macs07 is offline  
post #7 of 13 (permalink) Old 11-19-2013, 05:01 PM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Possibly ground issue.
I'd be popping the door sil and looking for broken wires, and or rusted out ground wire.



Sent from my iPhone using Tapatalk
Viper238 is offline  
post #8 of 13 (permalink) Old 11-19-2013, 10:08 PM Thread Starter
 
macs07's Avatar
 
Join Date: Oct 2008
Location: Toronto
Posts: 113
Thanks for all the info, damaged wire all repaired and working fine
macs07 is offline  
post #9 of 13 (permalink) Old 11-19-2013, 11:30 PM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
for reference for anyone else with this issue.

which one? and where?
Viper238 is offline  
post #10 of 13 (permalink) Old 11-22-2013, 02:05 PM Thread Starter
 
macs07's Avatar
 
Join Date: Oct 2008
Location: Toronto
Posts: 113
Sorry, it was the ground (black) in the boot between the D/door and the pillar. Spliced in a length, sodered, taped and shrinked.
macs07 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Tailgate Lock lildave F-150 2009 to 2014 Forum 1 05-06-2010 07:44 AM
Remote tailgate lock ricbeau F-150 2009 to 2014 Forum 5 08-26-2009 01:48 PM
Remote Tailgate lock MississaugaRanger Ranger Forum 7 01-30-2009 10:29 AM
Lock Test hogdust Test Section 3 01-08-2009 02:54 AM
Line Lock BapeStaarr Truck/SUV Talk 5 10-30-2008 08:56 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome