Help, not blowing air on any control. Vent, defrost, air conditioner.... - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
F-150 2004 to 2008 Forum XL, XLT, STX, LARIAT, FX4, FX2

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 02-05-2014, 03:39 PM Thread Starter
 
Arctic F-150's Avatar
 
Join Date: Jan 2009
Location: Kugluktuk, Nunavut
Posts: 92
Help, not blowing air on any control. Vent, defrost, air conditioner....

Not blowing any air at all in the air vent. 08 f150 supercab. Tried changing fuses F13-Climate control module power and F116-Blower Motor and still no air on any settings. Is there a different fuse I am missing or is it something else like a blower motor or something? No dealer so got to fix on my own.
Arctic F-150 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 02-05-2014, 04:00 PM
 
CanadianRanger's Avatar
 
Join Date: Mar 2008
Location: Saint John, NB
Posts: 1,901
Garage
Quote:
Originally Posted by Arctic F-150 View Post
Not blowing any air at all in the air vent. 08 f150 supercab. Tried changing fuses F13-Climate control module power and F116-Blower Motor and still no air on any settings. Is there a different fuse I am missing or is it something else like a blower motor or something? No dealer so got to fix on my own.
Did you try the blower motor resistor? I had one go on my Ranger. At first it just dropped one fan speed, then eventually only had one speed left.

2014 F150 FX4 | SuperCrew | 5.0L | 4x4 | Sterling Grey Metallic
CanadianRanger is offline  
post #3 of 19 (permalink) Old 02-05-2014, 04:11 PM Thread Starter
 
Arctic F-150's Avatar
 
Join Date: Jan 2009
Location: Kugluktuk, Nunavut
Posts: 92
Quote:
Originally Posted by CanadianRanger View Post
Did you try the blower motor resistor? I had one go on my Ranger. At first it just dropped one fan speed, then eventually only had one speed left.
Not sure, mainly used it only on 5 and 1. Is that inside the dashboard. Think I seen a pic of something behind the glove compartment with 2 screws and a connector? Will look into a new one.
Arctic F-150 is offline  
 
post #4 of 19 (permalink) Old 02-05-2014, 04:15 PM
 
CanadianRanger's Avatar
 
Join Date: Mar 2008
Location: Saint John, NB
Posts: 1,901
Garage
Yes behind glove compartment.

Here's a YouTube vid.

http://youtu.be/Sp-6-H1IRK8

Hopefully it's that simple for you.

2014 F150 FX4 | SuperCrew | 5.0L | 4x4 | Sterling Grey Metallic
CanadianRanger is offline  
post #5 of 19 (permalink) Old 02-05-2014, 05:23 PM Thread Starter
 
Arctic F-150's Avatar
 
Join Date: Jan 2009
Location: Kugluktuk, Nunavut
Posts: 92
Quote:
Originally Posted by CanadianRanger View Post
Yes behind glove compartment.

Here's a YouTube vid.

http://youtu.be/Sp-6-H1IRK8

Hopefully it's that simple for you.
OK Will try that. Is there a way to test if it is the resistor itself or the actual blower motor? I am thinking could also be the motor as none of the speeds work.
Arctic F-150 is offline  
post #6 of 19 (permalink) Old 02-05-2014, 05:43 PM
 
CanadianRanger's Avatar
 
Join Date: Mar 2008
Location: Saint John, NB
Posts: 1,901
Garage
Not sure about testing it. Someone else might chime in about that.
If parts aren't easy to get there, do you have a buddy with a F150? if so ask him to pull his resistor and try it in your truck before ordering a new blower.

2014 F150 FX4 | SuperCrew | 5.0L | 4x4 | Sterling Grey Metallic
CanadianRanger is offline  
post #7 of 19 (permalink) Old 02-05-2014, 06:21 PM Thread Starter
 
Arctic F-150's Avatar
 
Join Date: Jan 2009
Location: Kugluktuk, Nunavut
Posts: 92
Will try a new resistor first. When I switch from defrost and air conditioner settings can hear whining like it is trying to change from one to the others.
Arctic F-150 is offline  
post #8 of 19 (permalink) Old 02-05-2014, 09:14 PM
 
1white08fx2's Avatar
 
Join Date: Mar 2008
Location: London,Ont
Posts: 874
Like the others have stated, try the blower motor resistor. Mine was only blowing air on 3, and 4 settings, nothing with 1 or 2. I changed it out with a new oem one, and voila, it works again. Took me maybe 15, 20 minutes to swap it out, and put the new one in while it was cold out LOL!

2008 Oxford White F150 FX2 SPORT Super Crew,5.4L.
2003 Satin Silver Clearcoat Mustang GT,4.6L 2V,5 speed.
stripped,slammed,& cammed!

aka 1LOW03GT
1white08fx2 is offline  
post #9 of 19 (permalink) Old 02-05-2014, 10:52 PM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,513
Garage
The highest speed usually doesn't use the resistor. If you have no high speed, I'd check for power to the blower and if there is then the blower motor will probably need changing. Another possibility is the fan switch.

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #10 of 19 (permalink) Old 02-06-2014, 10:17 AM Thread Starter
 
Arctic F-150's Avatar
 
Join Date: Jan 2009
Location: Kugluktuk, Nunavut
Posts: 92
Quote:
Originally Posted by Destructicon View Post
The highest speed usually doesn't use the resistor. If you have no high speed, I'd check for power to the blower and if there is then the blower motor will probably need changing. Another possibility is the fan switch.
OK, I was thinking that also might not be the resistor as all speeds and all setting modes have no blower. Will try to find out where the blower motor is and the fan switch. Hoping they are as easy as getting to the resistor but by the looks of it guessing not. The wrenching part won't be the problem for me, just a matter of knowing where everything is.
Arctic F-150 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Air conditioning Ernie1956 F-150 2004 to 2008 Forum 22 05-13-2013 11:03 PM
NEED HELP: Fan blowing cold air? DavidY Ranger Forum 7 06-13-2012 07:32 AM
Air Compressor SKRWZ Tools 19 08-09-2011 10:36 PM
NEED HELP: heater blowing cold air westcoastranger Interior 18 11-28-2010 10:01 PM
Air Con macs07 F-150 1997 to 2003 /04 Heritage Forum 7 05-28-2009 10:26 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome