seatback vibration - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
F-150 2004 to 2008 Forum XL, XLT, STX, LARIAT, FX4, FX2

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-16-2008, 02:57 PM Thread Starter
 
Join Date: Oct 2008
Posts: 3
seatback vibration

hello all...new to forum and back in a ford..bought a 2003 f150 xlt with xtr package..4.6 ltr with 76000 klicks...very nice shape and am pleased with the truck overall...only prob im having is a vibration in the seat backs in the lumbar area..only when at full stop...i greased the lumbars and added a lttle foam to the lumbar..helpt abit..rpm is 650 in gear and 700 in nutural/park..idles nice amd runs smooth..was under the truck to check things out and finding the muffler vibrates alot..everything is fairly sound but muffler seems to have lots of vibration...thinkin a muffler change may help..factory muffler still on truck..anyway has anyone had this problem and if so your input would be welcome.....Thanks
bushboots is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-16-2008, 03:06 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
a common concern on these trucks was the exhuast mounts "grounding out",could usually be corected by lubing mounts with fluid film and loosen mount for exh on crossmember,torque eng fwd and rev and retighten mounts.hope that helps.and by the way welcome to the forum.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #3 of 7 (permalink) Old 10-16-2008, 03:38 PM
 
Fordwheeler's Avatar
 
Join Date: Aug 2008
Location: Calgary Alberta
Posts: 1,054
Welcome to the site. That sure is gonna be a tuff one to figure out.

1997 F-150 xl
1984 Honda XR200R (the toy)
2007 Honda CRF100f (the spare toy)
2005 Jayco Baja 10Y (the home away from home)
Fordwheeler is offline  
 
post #4 of 7 (permalink) Old 10-16-2008, 05:18 PM Thread Starter
 
Join Date: Oct 2008
Posts: 3
Thanks for the input...yes its not real bad but its there..if u up the revs just slightly the vibration disapears...truck is just like new so it tends to annoy me..being picky about it but if i can remidy it i will..will try the lube,loosen and torque thing and go from there..anyone elce have a suggestion....Thanks again
bushboots is offline  
post #5 of 7 (permalink) Old 10-16-2008, 05:48 PM
 
Fordwheeler's Avatar
 
Join Date: Aug 2008
Location: Calgary Alberta
Posts: 1,054
Just a guess but could it possibly be an engine damper going bad?

1997 F-150 xl
1984 Honda XR200R (the toy)
2007 Honda CRF100f (the spare toy)
2005 Jayco Baja 10Y (the home away from home)
Fordwheeler is offline  
post #6 of 7 (permalink) Old 10-17-2008, 08:25 PM Thread Starter
 
Join Date: Oct 2008
Posts: 3
thanks fella's
bushboots is offline  
post #7 of 7 (permalink) Old 10-17-2008, 08:42 PM
 
truckpilot's Avatar
 
Join Date: Nov 2007
Location: Orleans, Ont
Posts: 1,710
Welcome to the site

truckpilot is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP: LOUD vibration type noise RichmondRanger Ranger Forum 6 10-11-2008 09:52 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome