NEED HELP: HID problems - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Super Duty Forum ALL YEARS ALL MODELS

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-11-2011, 05:15 AM Thread Starter
gyz
Forum Newbie
 
Join Date: Mar 2011
Location: Windsor, Ontario
Posts: 1
Question HID problems

I have a 2001 F250 SuperDuty(canadian truck).
I converted my head light to 05-07 F250 one.
I am trying to put HID kit(high and low) in, but I get some problems.
With all original bulbs disconnect, and use the test light to check the ground, high beam power, and low beam power. It is showing the way should be. I only plug the HID harness on one side with all HID system plug in, , I check the other side bulb plug both high and low beam power have some kind of feedback. Like stay on low, high beam has feedback. Stay on high, low beam has feedback. I only get low beam and there is no high beam at all.
Please help me if anyone could figure it out.
Thank you.
gyz is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HID Kit cnelson09 F-150 2004 to 2008 Forum 10 12-01-2009 03:27 PM
more hid problems 08ranger Ranger Forum 11 11-08-2009 11:52 AM
HID Lights??? ChadH Lighting 8 11-24-2008 12:57 AM
HID install Northern Supercrew Lighting 20 09-29-2008 12:14 AM
HID problems BMac Lighting 7 08-18-2008 11:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome