NEED HELP: While driving my 2009 just wants to stop... why? - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Super Duty Forum ALL YEARS ALL MODELS

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-24-2013, 10:38 AM Thread Starter
 
Join Date: Apr 2009
Location: St-Lazare,Quebec
Posts: 50
While driving my 2009 just wants to stop... why?

Hi Guys, i have my 2009 SD at 38000 km and yesterday, a KEY appeared in the panel plus the truck while driving wants to stall, i push in the gas but it feels like it just wants to stop? What would be the problem? Filters or something else?

thanks

William!
will99 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-24-2013, 11:06 AM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Was it a key or a wrench?

Most likely mechanical.



Sent from my iPhone using Tapatalk
Viper238 is offline  
post #3 of 7 (permalink) Old 02-24-2013, 11:17 AM Thread Starter
 
Join Date: Apr 2009
Location: St-Lazare,Quebec
Posts: 50
Quote:
Originally Posted by Viper238 View Post
Was it a key or a wrench?

Most likely mechanical.



Sent from my iPhone using Tapatalk
it's a WRENCH
will99 is offline  
 
post #4 of 7 (permalink) Old 02-24-2013, 11:21 AM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,741
Garage
I'd vote mechanical as well....could be anything from a fouled O2 sensor to a clogged fuel filter, tough to tell without more info on how it's acting.

Time to go plug her in to the diagnostic and see what codes it's thrown.

801A - 6550 lb bundle of joy
SVT4MT is offline  
post #5 of 7 (permalink) Old 03-01-2013, 09:41 PM Thread Starter
 
Join Date: Apr 2009
Location: St-Lazare,Quebec
Posts: 50
Finally it was a sensor... when the girl called me to tell me that they had to open de transmission to check the problem, i was freaking out and i told the girl, " this truck NEVER PULLED, has ONLY 38000Km in 3.5 years, so what's going to be when it will be 8 years old? I have to send it to the scrap yard? "

She was loughing...

For now it's fixed,...

William!
will99 is offline  
post #6 of 7 (permalink) Old 03-26-2013, 08:41 AM Thread Starter
 
Join Date: Apr 2009
Location: St-Lazare,Quebec
Posts: 50
FIXED! It was a SENSOR... Thank god!
will99 is offline  
post #7 of 7 (permalink) Old 03-26-2013, 11:01 AM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Quote:
Originally Posted by will99 View Post
FIXED! It was a SENSOR... Thank god!
Good stuff.
What sensor?


Sent from my iPhone using Tapatalk
Viper238 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
working on the car today all welcome to stop by Racer Mitch Ontario 16 04-21-2008 06:02 PM
This looks like a good place to stop Biz Photo and Video Gallery - Members Rides 12 01-28-2008 10:48 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome