NEED HELP: No Wipers - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Super Duty Forum ALL YEARS ALL MODELS

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 10-14-2014, 08:13 PM Thread Starter
Apprentice
 
Join Date: Oct 2014
Location: Simcoe Ont
Posts: 9
Still no wipers

Hey All new to the forum, I have a 2004 ford super duty F350 King Ranch Dually With 6.0L diesel. I try my best at fixing things but FAR from really knowing what I'm doing lol.

Problem I have is my windshield wipers just stopped working. I have checked fuses and they are fine in fact I even changed them to be sure. I used them one day turned on next day nothing fluid not working either. I know small question but is there a relay or do I have to just change wipermotor?

Last edited by Sharosa; 10-22-2014 at 07:43 PM.
Sharosa is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 10-15-2014, 04:23 AM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,741
Garage
Welcome to fordtough.ca Iohn, great group of Canadian Ford owners here.

I'm no expert , but right off the top I'd check the switch if you're not getting wipers or the spray.

Motor might be just fine, wouldn't jump to replacing that right away, but that's just me.

801A - 6550 lb bundle of joy
SVT4MT is offline  
post #3 of 12 (permalink) Old 10-15-2014, 05:02 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,540
Garage
+1

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
 
post #4 of 12 (permalink) Old 10-15-2014, 09:17 AM
 
herbz's Avatar
 
Join Date: Dec 2007
Location: Cochrane, Alberta
Posts: 1,115
Send a message via MSN to herbz
Like others said. Start at the switch and work your way out.

2016 F150 XLT XTR 4x4 2.7 Ecoboost
herbz is offline  
post #5 of 12 (permalink) Old 10-15-2014, 08:05 PM Thread Starter
Apprentice
 
Join Date: Oct 2014
Location: Simcoe Ont
Posts: 9
thanks will do so tomorrow..
Sharosa is offline  
post #6 of 12 (permalink) Old 10-18-2014, 01:41 PM Thread Starter
Apprentice
 
Join Date: Oct 2014
Location: Simcoe Ont
Posts: 9
had switch checked it was fine. I purchased new wiper motor installed it still dead. There are 3 banks of modules behind battery and drivers side firewall. I cannot find anything that tells me what those relays are. Anyone have any idea? I have picture but cannot upload
Sharosa is offline  
post #7 of 12 (permalink) Old 10-18-2014, 02:23 PM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,741
Garage
I'll bet the wiper motor was reasonably priced.

I threw in my two cents with the switch, after that your guess is as good as mine, good luck with that, electrical gremlins are the best.

801A - 6550 lb bundle of joy
SVT4MT is offline  
post #8 of 12 (permalink) Old 10-19-2014, 07:50 AM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,540
Garage
Wiper control module, if it has one. Power relays, check fuses with a meter. Disconnected plug? Anything else not working?

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
post #9 of 12 (permalink) Old 10-19-2014, 10:29 AM Thread Starter
Apprentice
 
Join Date: Oct 2014
Location: Simcoe Ont
Posts: 9
Originally worked one day next day nothing washer fluid does not work either. I have replaced the wiper motor, I have metered fuses, I was told by ford that relays are in motor as it is a 12 wire harness going into wiper motor, I have disassembled signal/wiper/high bean switch and cleaned out old grease and reassembled. I have metered that there is 11.7 volts getting to the wiper motor and there us an extremely faint click when I turn wiper switch on. Signals work, high beams work, 4 ways work. again I have found 3 banks of relays between battery and drivers side firewall and cannot find any information what they are.
Sharosa is offline  
post #10 of 12 (permalink) Old 10-22-2014, 07:40 PM Thread Starter
Apprentice
 
Join Date: Oct 2014
Location: Simcoe Ont
Posts: 9
Well now I am in a pickle I hope someone will have the answer. I know wipers are not the most interesting thing to help with but please....

As of now I have checked all fuses and replaced them, I have changed the wiper motor and now just finished changing the switch still nothing. If anyone has anything please help. Thanks in advance.

John
Sharosa is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers wont shut off 9Lives F-150 2009 to 2014 Forum 7 04-13-2015 04:09 AM
Wipers Stopped Working herbz F-150 2004 to 2008 Forum 8 04-15-2011 01:46 PM
NEED HELP: windshield wipers Slasher Exterior 8 07-13-2009 08:47 PM
'02 f350 wipers and washer no worky Loadedagain Super Duty Forum 17 04-15-2009 08:34 PM
Opinions wanted for Wipers Matty Ranger Forum 19 01-19-2009 09:29 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome