Trouble Idling - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Super Duty Forum ALL YEARS ALL MODELS

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-14-2010, 09:01 AM Thread Starter
 
Jerf's Avatar
 
Join Date: Aug 2009
Location: Edmonton, Alberta
Posts: 17
Trouble Idling

I am getting CEL, codes that come up are P0191 (Fuel Rail Pressure Sensor Circuit Range/Performance), and P0452 (Evaporative Emission Control System Pressure Sensor Low Input). Intermittent rough idle/loss of power, black exhaust when idle becomes very rough and low rpm. It will sometimes stall or idle poorly when on slopes at low rpm, like crawling up a hill or traversing a side slope.

I took the truck to Ford, they replaced the fuel rail pressure sensor, did not fix problem. Took the truck to Ford in Fort McMurray, they diagnosed the issue as a partially blocked catalytic converter, code P0420 was present when I took the truck in but they cleared the DTC's and the code has yet to return after 400 km of driving.

Did not get the catalytic replaced because they wanted $4000 to replace the cat and do plugs (apparently 87000km is out of emissions warranty). I may have an exhaust shop cut out and replace the cancerous catalytic.

If any one out there has any clue as to what may be causing my rough idle/stall condition the help would be appreciated. The truck is an 08 F-350 with the 5.4 gas engine.
Jerf is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-14-2010, 03:36 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
you should have powertrain warranty to 100,000km,as for the running rough black smoke and plugged converter you should be looking at a injector concern,and the p0452 code sounds like a plugged evap vent valve.this should all be covered under powertrain/emisions.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #3 of 8 (permalink) Old 04-14-2010, 04:29 PM Thread Starter
 
Jerf's Avatar
 
Join Date: Aug 2009
Location: Edmonton, Alberta
Posts: 17
I thought that the emissions warranty would cover the catalytic repair as well, but Ford up here said I was out of it, having ended at 80,000km. I do have the powertrain warranty to 100,000km.

I forgot to mention that I am also getting a P06?? code (Can't remember the last 2 digits), reference voltage "A" circuit low. I do not know if that is diagnostic or simply related to the low voltage signal from the FRP sensor and Evap. Emission sensor.

Injector issue does make sense though, as the freeze frame data puts the fuel rail pressure at 0.00 Kpa.

I will be returning to Edmonton next Tuesday with the truck, any recommendations as to which Ford service shop to take it to? Already tried Team Ford, they replaced the FRP sensor.
Jerf is offline  
 
post #4 of 8 (permalink) Old 04-15-2010, 02:46 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
can't really help with which dealer to go to,my brother in edmonton got so upset with the level of service he was getting in edmonton that he started bringing his truck out here!as for the p06?code would to know the actual code number to diag(these are module power/communication codes)if you have a programmer these codes may appear after programming(it's one of the ways we can identify programmed vehicles)


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #5 of 8 (permalink) Old 04-15-2010, 06:06 PM Thread Starter
 
Jerf's Avatar
 
Join Date: Aug 2009
Location: Edmonton, Alberta
Posts: 17
I am collecting DTC's like stamps, another one showed up last night while I was working, P0454 Evaporative Emission System Pressure Switch/Sensor Intermittent. I guess that means the FTP sensor is done for.

I misquoted the P0191 code, it is actually P0192, if that makes any difference.

P0642, Sensor Reference Voltage A Circuit Low, is the code I couldn't remember yesterday. So all together I have collected P0192, P0452, P0454, and p0642 so far.
It will also sometimes squeal when it is having idle issues, the problem abates somewhat when I get the truck in gear and moving, but I am definitely down on power.

At this stage I would drive it out there if I could get this headache dealt with, I've done 2 different dealerships and gotten 2 misdiagnoses. If there is any way I could get this solved I would take it.
Jerf is offline  
post #6 of 8 (permalink) Old 04-16-2010, 12:06 AM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
you could have a vaccuum leak at the rear of the intake for the brake booster(the squealing noise and po192 as the frp uses vacc reference)ps..the lakeland has some of the best quad riding if you like it muddy


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #7 of 8 (permalink) Old 04-16-2010, 08:09 AM Thread Starter
 
Jerf's Avatar
 
Join Date: Aug 2009
Location: Edmonton, Alberta
Posts: 17
Huh, I didn't know brake boosters squealed when they had a leak, I thought it had to be the belt or a pulley. It does make sense though as the engine stumbles when the squealing is present. Vacuum leaks by themselves will cause rough idle, but I suppose on these returnless fuel systems without reference pressure the computer cannot correctly meter fuel. The squeal changes with rpm but so does vacuum as well, the only thing that gets me is that the squeal is intermittent. In the freeze frame data it has the FRP at 0.00, could this be because of bad reference vacuum?

The mud is intriguing, but I am usually done with mud after 2 weeks in the mine. I would like to meet you guys on the 18th but I have to work, oh well this summer with any luck.
Jerf is offline  
post #8 of 8 (permalink) Old 04-16-2010, 02:29 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
ya i here you i have to work this weekend also


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
Reply




Similar Threads
Thread Thread Starter Forum Replies Last Post
starting trouble oilman Excursion, Expedition, Navigator, Bronco, Explorer, Escape, Flex, Edge 8 11-23-2008 06:31 PM
Tranny Trouble BluByu1986 Driveline and Transmission 9 10-26-2008 08:39 PM
NEED HELP: Tranny trouble corpral diaz Ranger Forum 4 10-25-2008 11:48 PM
trouble codes marsden Truck/SUV Talk 2 05-02-2008 08:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome