Sluggish starting - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-11-2013, 10:13 PM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
Sluggish starting

Hey everyone, I noticed my 2000 PSD EX is starting sluggish the last couple of days. Last time it sounded like this one of the batteries was no good, replaced it and everything was fine. that was a couple of years ago. So when I noticed it doing the same, i tested both batteries with a cca tester and the one I replaced 2 yrs ago was good, now it was the other one, so i bought a new battery today cleaned the K&N air filter and it still starts sluggish. The alternator and the starter have been replaced within the last year and half.
Any suggestions?
George
oilman is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-12-2013, 04:50 PM
 
Canadian Bacon's Avatar
 
Join Date: Mar 2013
Location: Milton/ Georgetown, Ontario
Posts: 741
How's your oil? Synthetic or Conventional? What grade? Any additives? Ever changed injectors? How many KM's?

Nicole - 2004 Ford F-150 Lightning #3573
Emily - 2010 Ford F-150 FX4

Amsoil Independent Dealer
Amsoil Home Page
Canadian Bacon is offline  
post #3 of 6 (permalink) Old 08-12-2013, 07:44 PM
 
Destructicon's Avatar
 
Join Date: Mar 2010
Location: Stoney Creek, Ontario
Posts: 1,528
Garage
Check grounds to the engine block?

Electrician, powered by Tim Hortons, brought to you by Ford. Java Inside!
The Past - 1976 F-350 Crew Cab 1992 - 2006 RIP
The Past - 1995 F-150 XL Enforcer All Gear Drive 2008 - 2015
The Present - 1993 F-250 XLT Turbo Diesel Super Cab 4x4 2015 - ?
The Future - Who knows?
Destructicon is offline  
 
post #4 of 6 (permalink) Old 08-12-2013, 08:40 PM
 
1white08fx2's Avatar
 
Join Date: Mar 2008
Location: London,Ont
Posts: 874
Plus one with the above..... at the same time, wouldn't hurts to test the battery, or altenator too. Doesn't matter if either were replaced within the last year or not. I've seen it where an altenator kept being an issue on a buddy's car once, they were just defective from the supplier. The factory oem one will go on for a long time, but the replacement ones could last a year, or less, or more, same goes for the battery.
Even dirty battery terminals will give you issues. It's good to keep those clean yearly, preferably after winter in the spring.

2008 Oxford White F150 FX2 SPORT Super Crew,5.4L.
2003 Satin Silver Clearcoat Mustang GT,4.6L 2V,5 speed.
stripped,slammed,& cammed!

aka 1LOW03GT
1white08fx2 is offline  
post #5 of 6 (permalink) Old 08-12-2013, 09:44 PM Thread Starter
 
Join Date: May 2008
Location: Brampton, Ontario
Posts: 43
It was the starter.
oilman is offline  
post #6 of 6 (permalink) Old 08-15-2013, 10:10 PM
 
1white08fx2's Avatar
 
Join Date: Mar 2008
Location: London,Ont
Posts: 874
Congrats..... Easy fix.

2008 Oxford White F150 FX2 SPORT Super Crew,5.4L.
2003 Satin Silver Clearcoat Mustang GT,4.6L 2V,5 speed.
stripped,slammed,& cammed!

aka 1LOW03GT
1white08fx2 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting the truck hyperhad F-150 2009 to 2014 Forum 3 08-17-2012 10:35 PM
starting issues/ truckguy94 F-150 Pre-1997 Forum 20 05-19-2010 06:32 PM
Starting up Mar Ranger Forum 3 02-28-2010 11:01 AM
starting trouble oilman Excursion, Expedition, Navigator, Bronco, Explorer, Escape, Flex, Edge 8 11-23-2008 06:31 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome