stereo problem - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Audio and Electronics Alarms, Audio Systems, DVD and GPS Systems

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-31-2008, 04:46 PM Thread Starter
 
martyF150XTR's Avatar
 
Join Date: Jan 2008
Location: elliot lake
Posts: 71
Send a message via MSN to martyF150XTR
stereo problem

hey guys i don't know whats wrong with my stock radio wen the truck is running i cant turn on my radio, the only thing running is the clock is my deck fried????

i tried to change the fuse and still nothing ?

sorry i put my thread in the wrong place i should of put it in a diferent place

MARTYXTR
martyF150XTR is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-31-2008, 05:41 PM
 
Smokefan's Avatar
 
Join Date: Feb 2007
Location: London, Ontario
Posts: 3,988
Can't help you with deck, but I'll re-locate thread to proper section

2011 Chevrolet Camaro RS2SS
2007 Pontiac Grand Prix GXP
2007 Ford Crown Victoria P71


Smokefan is offline  
post #3 of 7 (permalink) Old 03-31-2008, 07:03 PM
 
Bush_aholic's Avatar
 
Join Date: Dec 2007
Location: Elliot Lake, Ontario
Posts: 2,108
Send a message via MSN to Bush_aholic
Marty take it out and check all the sodered wires and your ground, make sure nothing's shorting out and thiere well insulated. I'm coming Home wednesday I'll check it out


I only drive in the city, to get out of it!!!
Bush_aholic is offline  
 
post #4 of 7 (permalink) Old 03-31-2008, 08:10 PM Thread Starter
 
martyF150XTR's Avatar
 
Join Date: Jan 2008
Location: elliot lake
Posts: 71
Send a message via MSN to martyF150XTR
ok cool

hey go on msn

MARTYXTR
martyF150XTR is offline  
post #5 of 7 (permalink) Old 04-17-2008, 10:23 AM Thread Starter
 
martyF150XTR's Avatar
 
Join Date: Jan 2008
Location: elliot lake
Posts: 71
Send a message via MSN to martyF150XTR
i found the problem did you know that their is four fuses that are connected to your deck lol

MARTYXTR
martyF150XTR is offline  
post #6 of 7 (permalink) Old 04-17-2008, 04:55 PM
 
Join Date: Nov 2007
Posts: 76
lol, good 'ol technology eh?
Dazed is offline  
post #7 of 7 (permalink) Old 04-17-2008, 10:45 PM
 
Viper238's Avatar
 
Join Date: Aug 2007
Location: Woodstock, Ont
Posts: 3,353
Send a message via MSN to Viper238
Sorry dude.. I didn't see the thread till today..
I was gunna mention there is usually more then 1 fuse feeding the radio..
Viper238 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tell us about your truck's stereo or stereo plans!! fordtough.ca Audio and Electronics 42 04-23-2010 07:37 PM
2007 f150 stereo Bush_aholic F-150 2004 to 2008 Forum 13 01-13-2008 07:52 PM
Same problem or new one?? Ottawaguy F-150 Pre-1997 Forum 11 01-02-2008 12:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome