NEED HELP: With 2007 FX2 audio upgrades? - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Audio and Electronics Alarms, Audio Systems, DVD and GPS Systems

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-10-2008, 04:47 PM Thread Starter
 
Join Date: Jul 2008
Posts: 55
With 2007 FX2 audio upgrades?

Okay, so have the 6disc premium system, which we just upgraded with 6disc navigation w/subwoofer.
Just got installed today, dealer said no subwoofer plug for the head unit, but it looks to have the plug at the rear set, just pulled it out, might be for the rear defroster?, but I don't know. Anyone out there have a pic, or two or three, they could post that shows the plug ends for the factory subwoofer?

Also, how easy is it to pull the head unit out to see what is there? can't seem to find any way to pull off the plastic cover, covering the head unit.

Thanks in advance!
04STXHERITAGE is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-10-2008, 05:45 PM
 
fordtough.ca's Avatar
 
Join Date: Feb 2007
Location: GTA
Posts: 7,721
Quote:
Originally Posted by 04STXHERITAGE View Post

Also, how easy is it to pull the head unit out to see what is there? can't seem to find any way to pull off the plastic cover, covering the head unit.

Thanks in advance!
It just clips in
Pull on it from the bottom towards you
The first time you remove it will be hard but after that it will go easy
Remove from the bottom install from the top



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
fordtough.ca is offline  
post #3 of 7 (permalink) Old 11-11-2008, 06:06 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
the connector is under back seats flat grey in color with 10 pins.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
 
post #4 of 7 (permalink) Old 11-11-2008, 08:16 PM
 
Join Date: May 2008
Location: calgary alberta
Posts: 73
open the ashtray and use that to pull the surround off
and the radio is held on my 4 bolts
blackdf150 is offline  
post #5 of 7 (permalink) Old 11-11-2008, 09:39 PM Thread Starter
 
Join Date: Jul 2008
Posts: 55
Quote:
Originally Posted by shelbyx1 View Post
the connector is under back seats flat grey in color with 10 pins.
Thanks! like this..?










Well, thanks for the advice, I couldn't (didn't want to) pull off the cover, covering the head unit, thought I was going to break it, so I went from under the steering wheel and the centre console(sp?), looked at the back of the head unit. There where only two plugs (big and the medium) used in the back of the unit, I followed the wire harness back and low and behold the were two leads folded and taped back. One (small) grey, one (small) black, the grey one had an adapter on it, removed it and it plugged right into the subwoofer jack on the back of the head unit. The black one?, I don't know, maybe for the hands free phone?
The subwoofer lead was folded back under the carpet of the rear seat, right hand side, just undid the clip from the floor and feed it through the already there slit in the carpet.

None to happy with the dealership who did the install, told me there was no third lead for the subwoofer, I told them to follow the harness, like I did, said they couldn't find it, also asked me where the gps antenna was to be mounted!???, I told them how am I supposed to know, check the repair manual, they said they would look it up on the 'net', I asked don't they have the repair manual?, no answer. None to bright...

Just need to get the OEM subwoofer box, junk the speaker and maybe the amp, install the kenwood pieces and it'll be done!!, after I do the install, can't count on the dealership to do it right, clowns....
04STXHERITAGE is offline  
post #6 of 7 (permalink) Old 11-12-2008, 12:18 PM
 
shelbyx1's Avatar
 
Join Date: Oct 2008
Location: bonnyville alberta
Posts: 2,401
that looks like the conn in service manuels,what dealership you dealling with?universal in calgary has some qualified techs.


a moments silence for the shelbyx,i hope her new owner enjoys as much.
shelbyx1 is offline  
post #7 of 7 (permalink) Old 11-13-2008, 01:54 AM
 
Join Date: May 2008
Location: calgary alberta
Posts: 73
universal
where i bought my truck
blackdf150 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
97 psd upgrades drford Diesel Engines 11 02-13-2009 08:14 PM
Audio Wiring Justin1635 Audio and Electronics 2 10-26-2008 06:06 PM
FX2 20" OEM Rims Ross Wheels and Tires 9 04-23-2008 10:36 PM
New Upgrades!! Viper238 Photo and Video Gallery - Members Rides 28 11-27-2007 10:01 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome