94 Explorer Audio Problems - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Audio and Electronics Alarms, Audio Systems, DVD and GPS Systems

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-31-2009, 01:33 PM Thread Starter
Apprentice
 
Join Date: Feb 2009
Location: Winnipeg Mb
Posts: 6
94 Explorer Audio Problems

Ive just put an Alpine CD player into my Explorer. Used the aftermarket install harness, Only plays on the Left channel, thought it could have been the Factory amp (Premium Sound, NOT JBL) so I went and picked up the bypass harness for that, still have the same problem, any ideas other than just hard wiring the the Speakers in ?


PS Its not the deck, I tried the deck out of the truck and it works fine

"Dont hit brick walls, They hurt"
RacerM95 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-31-2009, 03:37 PM
 
Phil G.'s Avatar
 
Join Date: Jun 2008
Location: Peterborough, ON
Posts: 529
if you are bypassing the amp anyways (which is what I think I am reading), I would run new heavier speaker cable to the speakers. The hardest part is getting the wire through the door boots but thats not too bad once you get onto it. Then at least if you decide to add an amp later, you already have the wiring run. If you run two sets at the same time, you can later add componet speakers if you want and the X-overs will be inside the vehicle instead of in the doors. The doors are not a good place for them anyways.
Phil G. is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
04 Explorer heavyhitter Excursion, Expedition, Navigator, Bronco, Explorer, Escape, Flex, Edge 6 12-20-2008 06:00 PM
NEED HELP: With 2007 FX2 audio upgrades? 04STXHERITAGE Audio and Electronics 6 11-13-2008 01:54 AM
Audio Wiring Justin1635 Audio and Electronics 2 10-26-2008 06:06 PM
92 explorer lift bob_loblaw Wheels and Tires 1 04-27-2008 02:24 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome