Truck wont Start ! - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 24 (permalink) Old 09-30-2013, 01:40 AM Thread Starter
 
CDM76's Avatar
 
Join Date: Feb 2010
Location: Grande Prairie, Alberta
Posts: 323
Truck wont Start !

So, the last 3 times I filled my tank (was on a road trip) the engine would not start immed after filling it with gas. Once was 1/2 tank before filling, once was 1/4 and once the fuel light was flashing. All 3 times exact same symptoms.

I place foot on brake and turn key in ignition, starter turns over but truck wont start. I turned it off and waited. Still wouldnt start. So first time I hammered on the gas as turning key, started for about 10 secs then stalled (flooded ). Next 2 times I gently feathered the gas while turning ignition and it caught. I then sat there revving gas for about 20-30 seconds and then worked fine again.... until next fill up.

Each time I made multiple smaller trips around the towns I was in, stopping to visit ppl, and go for supper, drive to golf course, etc and no problems. It is ONLY when filling with gas.

I was at 3 different gas starions (Shell, Costco, Esso) in 3 separate towns all about 500-700 km apart.

Truck : 5.4L 2010 F150. 46,000km No engine mods. No chip.

I'm leaning towards the fuel pump, but any other suggestions about whats going on ? Its going into the dealer tomorrow morning. Thankfully, I have extended warranty !
CDM76 is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 09-30-2013, 01:13 PM
 
Mrmagoo's Avatar
 
Join Date: Dec 2011
Location: Grande Prairie, AB
Posts: 1,566
Could be pump or filter. Hard to tell anymore on these things. No check engine light?
I've got a basic code reader here you can have if you want C. PM me for address.

Such is life. Just passing through.

04 F150 FX4 Screw 5.4 with couple of mods
Mrmagoo is offline  
post #3 of 24 (permalink) Old 09-30-2013, 01:16 PM Thread Starter
 
CDM76's Avatar
 
Join Date: Feb 2010
Location: Grande Prairie, Alberta
Posts: 323
No engine light. The oil light came on and stayed steady but that's it.
Didn't even think of fuel filter. When filter went on my bike was more gradual though. Hmmm. Food for thought though.
CDM76 is offline  
 
post #4 of 24 (permalink) Old 09-30-2013, 08:07 PM Thread Starter
 
CDM76's Avatar
 
Join Date: Feb 2010
Location: Grande Prairie, Alberta
Posts: 323
Truck sat at shop all day and they didnt even look at it. Gonna be some heads rolling if nothing again tomorrow !
CDM76 is offline  
post #5 of 24 (permalink) Old 09-30-2013, 11:51 PM
 
Northern Supercrew's Avatar
 
Join Date: Jan 2008
Location: watson lake, yukon
Posts: 4,280
Send a message via MSN to Northern Supercrew
Are the filters in the tank on that series and part of the pump assembly?

2013 f150 Ecobeast
3.55 E locker
FX4 Screw
SSI tuned!!!!!!!!!!!!!!!!!
Northern Supercrew is offline  
post #6 of 24 (permalink) Old 10-01-2013, 12:29 PM
 
Canadian Bacon's Avatar
 
Join Date: Mar 2013
Location: Milton/ Georgetown, Ontario
Posts: 741
^Correct.

Filters are not serviceable anymore. Could be the Fuel Pump Driver (but would be more frequent not just after filling) or Pump itself by the sounds of it.

Nicole - 2004 Ford F-150 Lightning #3573
Emily - 2010 Ford F-150 FX4

Amsoil Independent Dealer
Amsoil Home Page
Canadian Bacon is offline  
post #7 of 24 (permalink) Old 10-01-2013, 08:38 PM Thread Starter
 
CDM76's Avatar
 
Join Date: Feb 2010
Location: Grande Prairie, Alberta
Posts: 323
Well I got truck back today, and they replaced the Evaporative Emission Canister and the Purge Valve. Thankfully I have extended warranty !
CDM76 is offline  
post #8 of 24 (permalink) Old 10-01-2013, 11:14 PM
 
Mrmagoo's Avatar
 
Join Date: Dec 2011
Location: Grande Prairie, AB
Posts: 1,566
Good for you C. Hopefully that was it and things are fine now.

Such is life. Just passing through.

04 F150 FX4 Screw 5.4 with couple of mods
Mrmagoo is offline  
post #9 of 24 (permalink) Old 10-04-2013, 09:35 PM
 
Join Date: Feb 2009
Location: Whitehorse, YT
Posts: 71
Was going to pipe in with the purge valve ...... they have a penchant for staying slightly open on these things. when you fuel up the mass of vapours in the fuel tank get pushed into the charcoal canister. they should normally be contained there until it's time for normal purging into the intake, but with the purge valve sticking open the vapours instead go right into the engine. your air:fuel mix goes way rich and you get a hard/no start.

it's surprising that you didn't get a P0451 for incorrect evap flow.

2003 GMC Sierra 3500 -- dually, 4x4, hasn't blown up yet and that's what i look for in a truck

Ford Doctor -- They come in broken and leave fixed. Ford of Canada Master Tech
Varsity Tyler is offline  
post #10 of 24 (permalink) Old 10-04-2013, 10:01 PM Thread Starter
 
CDM76's Avatar
 
Join Date: Feb 2010
Location: Grande Prairie, Alberta
Posts: 323
Thanks for the explanation. Makes sense
Considering it is the first issue I've had since I bought the truck 3 yrs ago its not bad.
And with extended warranty, no costs
CDM76 is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP: Truck won't start meecraw Ranger Forum 10 08-23-2011 09:41 PM
NEED HELP: truck would not start.. '88ranger Ranger Forum 6 06-03-2011 10:36 PM
i need help please..truck wont start sandman F-150 Pre-1997 Forum 12 01-15-2010 02:41 PM
Truck wouldnt start ??? BigDawg99 F-150 2004 to 2008 Forum 3 09-25-2008 10:05 PM

Posting Rules  
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome