NEED HELP: 87 ranger 4×4 2.9 no fire from coil. So far. - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 3 (permalink) Old 04-05-2015, 02:37 PM Thread Starter
Forum Newbie
 
Join Date: Apr 2015
Location: Nebraska, USA
Posts: 2
87 ranger 4×4 2.9 no fire from coil. So far.

Now I know its Easter Sunday. Been through this once before bout a year ago. Just all the sudden BAM it dies, will not start. That's how it happened the first time. Replaced all electrical components. It started after the last one. This time a little different. Started bout a week ago, sputtered coming to a stop light, almost died, but didn't. Couple nights later it dies. Starts back up. Couple nights later it dies rather abruptly, starts, dies, starts, dies. I'm thinking fuel filter clogged or sending unit in tank. Let it sit for 5 mins. Starts, gets us home. Go to Walmart to get a filter, cause its after hours. It dies leaving the parking lot. Next morning change filter, old one smelled bad. Now. No fire. So the last part I replaced last year, first one I check this time. ICM. On the distributer. Have it tested. Its bad. Replace. Still no fire. Just got it towed home this morning. Any ideas?
essrainz00 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-05-2015, 11:57 PM Thread Starter
Forum Newbie
 
Join Date: Apr 2015
Location: Nebraska, USA
Posts: 2
Update. I know everybody's dying from anticipation. Replaced fusible link coming out of coil plug. Awesome. I do like the forums.
essrainz00 is offline  
post #3 of 3 (permalink) Old 04-06-2015, 06:49 AM
 
SVT4MT's Avatar
 
Join Date: Aug 2010
Location: Port Elgin, Ontario
Posts: 4,741
Garage
Glad to hear it all worked out, I had nothing for you, almost sounded like the situation when my wife's MAF sensor got some debris on it, but figured that was not the case here.

Welcome to the home of the Canadian F150 (and Ford) enthusiast.

801A - 6550 lb bundle of joy
SVT4MT is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
has anyone tried the accel coil packs Greg Coleman Ontario 3 03-04-2014 07:11 AM
any sugestions about the coil packs Greg Coleman F-150 2009 to 2014 Forum 8 08-15-2013 09:53 PM
Coil Packs stormy663 F-150 1997 to 2003 /04 Heritage Forum 6 05-23-2012 12:00 AM
Coil packs Destructicon Gas Engines 7 03-27-2012 08:20 PM
Front Coil Springs JTSF150 Suspension 1 06-16-2010 05:13 PM

Posting Rules  
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome