NEED HELP: It just died.... Alternator? - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 4 (permalink) Old 11-26-2008, 03:12 PM Thread Starter
 
Join Date: Jun 2008
Location: Ft St John, BC
Posts: 43
It just died.... Alternator?

Hey guys,
my truck has been acting wierd during the cold weather, the truck almost seems to have no juice coming from the battery, or alt. when its idling the voltometer guage drops to the beginning of NORMAL where it then jumps up to the M when driving. I swapped out the terminals because one was broke and the other was really corroded and the truck seemed to work good but it was also above zero when I drove it.

Then this morning when I was at a set of lights with my turn signal on my stereo cut out and my dash lights dimmed at every click of the signal. And then when I came home the needle was jumping all over the place. and after i shut it off and went to turn it back on, I got nothing, not even accessory power. now, the starter solenoid has a busted stud from the previous owner so he siliconed the wires to the remnants of the stud, and when my truck used to just die when it was being started Id just clean off both battery terminals and jiggle the wires on the solenoid and it would fire up. Any ideas?
Jensen is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-26-2008, 03:46 PM
 
Join Date: Jan 2008
Location: Brantford
Posts: 75
I'd replace the solenoid. A bad connection there could give you all the problems you listed.

1968 F100 428
2010 Ranger Xl 2.3
2008 Edge
jimmyk is offline  
post #3 of 4 (permalink) Old 11-26-2008, 04:31 PM Thread Starter
 
Join Date: Jun 2008
Location: Ft St John, BC
Posts: 43
just swapped solenoid, had a spare in glove box and that wasnt it swapped battery had a spare on truck floor cause I thought that was the original problem and it ran until I turned on the radio and driving lights and it jumped back down to beginning of N. So Im going to assume alt. now I just have to wait till the wife comes home so I can go to Canadian tire and get it checked or replaced
Jensen is offline  
 
post #4 of 4 (permalink) Old 11-28-2008, 09:53 PM Thread Starter
 
Join Date: Jun 2008
Location: Ft St John, BC
Posts: 43
yup, it was the alternator thanks for the advice though.
Jensen is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bigger Alternator Roadwarrior F-150 2004 to 2008 Forum 13 06-12-2008 11:39 AM
Alternator pulley switching blueghost Gas Engines 1 06-12-2008 12:07 AM
Fancy alternator blueghost Wheels and Tires 7 04-23-2008 09:21 PM

Posting Rules  
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome