NEED HELP: Truck Not starting - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 22 (permalink) Old 12-14-2008, 01:05 PM Thread Starter
 
BigDawg99's Avatar
 
Join Date: Jul 2008
Location: NB Canada
Posts: 37
Truck Not starting

i got a 2004 Ford F150 with the 5.4...The other night i came home from a long day of Driving..I reversed into my Driveway which is not Extremely Sloped..In about 15 minutes..i got in my truck and it started..i did not make it all the way out of the driveway and she stalled..She would start but stall..i parked the truck and Put gas line antifreeze in it and Hooked up the Hott plug to it..I still cant get the truck started..she has a good crank but doesnt want to jump..i pressed the fuel pump reset switch and nothing..No codes are coming up..I checked the Fuse and its good..when we turn the key..you cant hear the pump going..but i have never had a problem with the truck just that minute..no signs the fuel pump was going or anything..Would someone here know what the Heck is wrong with my truck..

Fire Fighter 19
BigDawg99 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 12-14-2008, 01:12 PM
 
Justin1635's Avatar
 
Join Date: Aug 2008
Location: MB
Posts: 215
put the key in, turn it on, but dont start it, you should hear the fuel pump priming, if not. thats where you gotta start from and work your way in.

edit: lol you said you did try that, forgive me im hungover. well looks like it has to do with the fuel pump, i'd wait to see what shelby says then go from there.

"The Dark Knight"
Justin1635 is offline  
post #3 of 22 (permalink) Old 12-14-2008, 02:25 PM Thread Starter
 
BigDawg99's Avatar
 
Join Date: Jul 2008
Location: NB Canada
Posts: 37
thanks man..

Fire Fighter 19
BigDawg99 is offline  
 
post #4 of 22 (permalink) Old 12-14-2008, 02:36 PM
 
Join Date: Jun 2008
Location: Abbotsford, B.C.
Posts: 30
Check your fuel pump fuses?
Calm is offline  
post #5 of 22 (permalink) Old 12-14-2008, 02:57 PM
 
Join Date: Sep 2008
Location: Spruce Grove, Alberta
Posts: 68
Just a thought pop the top of your airbox, see if air filter is frozen or wet,
MAP won't let truck run if it does'nt register air.
My Ranger did something like that this past summer, MAP failed.

SD
Snowdoogie is offline  
post #6 of 22 (permalink) Old 12-14-2008, 03:02 PM Thread Starter
 
BigDawg99's Avatar
 
Join Date: Jul 2008
Location: NB Canada
Posts: 37
i checked and even replaced the fuel pump fuse..not sure if it has a relay or not but i never seen one anywheres or in the Manual..I also checked the Air Filter and it was dry and in really good shape..

Fire Fighter 19
BigDawg99 is offline  
post #7 of 22 (permalink) Old 12-14-2008, 03:06 PM
 
Northern Supercrew's Avatar
 
Join Date: Jan 2008
Location: watson lake, yukon
Posts: 4,280
Send a message via MSN to Northern Supercrew
ok...this may sound like a dumb response...but what is your fuel level at? you did mention being on a slight incline..could it be that your gas is at the wrong end of the tank and not getting picked up? just throwing it out there.

2013 f150 Ecobeast
3.55 E locker
FX4 Screw
SSI tuned!!!!!!!!!!!!!!!!!
Northern Supercrew is offline  
post #8 of 22 (permalink) Old 12-14-2008, 09:07 PM Thread Starter
 
BigDawg99's Avatar
 
Join Date: Jul 2008
Location: NB Canada
Posts: 37
my tank is Full..im kinda hoping i dont have to empty out the tank to change the fuel Pump...

Fire Fighter 19
BigDawg99 is offline  
post #9 of 22 (permalink) Old 12-14-2008, 09:11 PM
 
Join Date: Nov 2008
Posts: 48
hows the fuel filter looking? if its clogged up it might not be getting enough gas? also if you change the fuel pump..you're gonna want to empty your tank or else thats weight
heavyhitter is offline  
post #10 of 22 (permalink) Old 12-14-2008, 09:18 PM
 
murray99's Avatar
 
Join Date: Jun 2008
Location: Pitt Meadows BC
Posts: 686
Give the tank a smack with a piece of wood while someone tries starting the truck. Some times fuel pumps get hung up on the brushes and giving the tank a smack it move the impeller and the truck will start.


Last edited by murray99; 12-14-2008 at 10:04 PM.
murray99 is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
starting issues/ truckguy94 F-150 Pre-1997 Forum 20 05-19-2010 06:32 PM
starting trouble oilman Excursion, Expedition, Navigator, Bronco, Explorer, Escape, Flex, Edge 8 11-23-2008 06:31 PM
Cold Weather Starting Ottawaguy F-150 Pre-1997 Forum 9 02-21-2008 10:50 PM

Posting Rules  
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome