HELP! truck won't start! - FordTough.ca - Home of Canadian Ford Truck Enthusiasts
Reply
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
post #1 of 15 (permalink) Old 09-04-2007, 04:12 PM Thread Starter
 
Join Date: Aug 2007
Posts: 245
HELP! truck won't start!

I go to start my truck and she won’t start. I can sometimes get the radio to turn on when I have to key selected to battery. With the key in position 2, there is no display lights, key chime (w/ door open) or anything! When I put the key to ignition the “theft” light comes on solid red. I can’t lock my doors or put up the windows. When I open the door or try to lock the door with the remote there is a relay that ticks every half second and all lights (interior and exterior) blink with the sound of the relay.
My first thought was to disconnect the battery as maybe there is something that needs to be reset. Nothing, so I take out the battery and put it on the charger, but it says 100% and 13.65V. I drove the truck about 3 hours prior to this happening.
I asked my neighbour (a ford tech) for help. He figures the relay is clicking because there is no voltage from the battery (the battery is dead). We boost it and she starts, and indicates a charging voltage of 14.65V.
I drive for about 30min and turn her off. As soon as I open my door the lights starting flickering to the relay ticking again, then stops when I close the door. I haven’t tried to restart her as I had to leave an hour prior to this happening.
Is my battery just plain dead?
Does anyone know why there was all this weird stuff happening just because the battery may be bead, or could it be something else???
lightning25 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 09-04-2007, 05:25 PM
 
Smokefan's Avatar
 
Join Date: Feb 2007
Location: London, Ontario
Posts: 3,988
Could the relay be shorting out causing the battery to die? Which relay is clicking?

2011 Chevrolet Camaro RS2SS
2007 Pontiac Grand Prix GXP
2007 Ford Crown Victoria P71


Smokefan is offline  
post #3 of 15 (permalink) Old 09-04-2007, 05:50 PM Thread Starter
 
Join Date: Aug 2007
Posts: 245
I have no idea which relay is clicking....possibly all of the ones what would operate when i open the door or turn the key to pos 1 or 2 (to make the chime).
i have sent this on other sites and i am getting info back that relays are clicking because there is not enough voltage to keep them on. basically the battery is dead.

I posted this on svtperformance.com if you want to see what people have wrote.

I am going to try a "draw test" too, to see if there is anything in the truck causing it to die, although i doubt it as i just drove the truck a few hours eariler with no problems starting.

So off to FORD for a new battery i suppose.
lightning25 is offline  
 
post #4 of 15 (permalink) Old 09-04-2007, 05:53 PM
 
Smokefan's Avatar
 
Join Date: Feb 2007
Location: London, Ontario
Posts: 3,988
Warranty? Some batteries just die, my Mustang did the same thing. Started and stopped no problem while working on it in the driveway than when it was time to move it for safety...nothing!

2011 Chevrolet Camaro RS2SS
2007 Pontiac Grand Prix GXP
2007 Ford Crown Victoria P71


Smokefan is offline  
post #5 of 15 (permalink) Old 09-04-2007, 06:12 PM
 
fordtough.ca's Avatar
 
Join Date: Feb 2007
Location: GTA
Posts: 7,721
Quote:
Originally Posted by lightning25 View Post
Is my battery just plain dead?
Yep,
Time for a new battery



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
fordtough.ca is offline  
post #6 of 15 (permalink) Old 09-04-2007, 06:26 PM Thread Starter
 
Join Date: Aug 2007
Posts: 245
i think it's the original battery, so it's about time if it is.
As for warranty, i don't know when it was changed, but it's okay...better than some electrical problem! :spz:
lightning25 is offline  
post #7 of 15 (permalink) Old 09-04-2007, 06:34 PM
 
Smokefan's Avatar
 
Join Date: Feb 2007
Location: London, Ontario
Posts: 3,988
Get a good one, cheap batteries don't last.

2011 Chevrolet Camaro RS2SS
2007 Pontiac Grand Prix GXP
2007 Ford Crown Victoria P71


Smokefan is offline  
post #8 of 15 (permalink) Old 09-04-2007, 06:47 PM Thread Starter
 
Join Date: Aug 2007
Posts: 245
i'll be going to ford to get a motomaster one
lightning25 is offline  
post #9 of 15 (permalink) Old 09-04-2007, 10:24 PM
Biz
 
Join Date: Feb 2007
Posts: 1,409
Quote:
Originally Posted by lightning25 View Post
i'll be going to ford to get a motomaster one
Before you do that..check Costco for interstate..just as good and way less the price.
Biz is offline  
post #10 of 15 (permalink) Old 09-05-2007, 08:54 AM
 
Smokefan's Avatar
 
Join Date: Feb 2007
Location: London, Ontario
Posts: 3,988
Ya, the interstate I put in the 5.0l was strong like bull.

2011 Chevrolet Camaro RS2SS
2007 Pontiac Grand Prix GXP
2007 Ford Crown Victoria P71


Smokefan is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Start engine button Spinal Interior 37 05-12-2010 08:11 PM
NEED HELP: truck won,t start mackmanken F-150 2004 to 2008 Forum 15 10-13-2008 10:17 PM
Truck wouldnt start ??? BigDawg99 F-150 2004 to 2008 Forum 3 09-25-2008 10:05 PM
The start of my next mod! veskeyw Projects and Build-Ups 11 05-21-2008 11:26 PM
engine noise on start up??? silverfox Gas Engines 14 09-24-2007 10:50 PM

Posting Rules  
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome