Ford Tough - Home of Canadian Ford Truck Enthusiasts banner
1 - 20 of 32 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
What a night! Driving back from supper last night......pulling up to a stop light and the truck shuts off. Middle of a snowstorm, wife and kid in the truck, and it absolutely refuses to start. Manage to get the truck off to the side of the road, but after hours of freezing my a$$ off, still nothing. Finally have to break down and call a tow truck. :no:

You know how hard it is to watch a 3 month old truck get towed away?:cry2: Was I ever pissed.

Truck is in the shop right now, should hear back shortly. I'm just praying that the Edge tuner had nothing to do with this, else I'm screwed.

Will keep you posted.
 

·
Registered
Joined
·
3,988 Posts
That sucks man! Please keep us posted.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #6 ·
Dealer is now saying that it was caused by the aftermarket starter/alarm that I installed, but I know this isn't possible. They are just trying to find something to blame it on. 6 hours in the shop and they still don't know what it is. Will update soon.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #7 ·
8 hours later they finally diagnose the problem to a wiring harness, and not anything aftermarket. Apparently they have had this problem with several 07 F150s already this year.

The good news is that it's covered under warranty. The bad news is that I won't get my truck until tomorrow, and even then it's still only a temporary fix. Have to bring it back again when the new harness gets in.:ang:
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #11 ·
Wow that someting
You are lucky they didn't find the edge in there,
They wouldnt even touch the truck
Did they give you a rental vehicle?
Ha. Nope.

Just got off the phone with them again. They had to order in a new wiring harness from the U.S., which won't be in until next Tuesday. In the meantime, they are telling me that if I want my truck back I have to pay for a temporary fix :lol:. They also said that because I didn't buy extended warranty, they won't supply a rental.

So, to recap, it's a factory defect on a brand new vehicle, I'll be without my truck for 5 days, they won't supply a rental, and I have to pay for a temp fix if I need a way to get back and forth to work. All makes perfect sense...doesn't it?

I honestly couldn't believe what I was hearing. Needless to say, I had a few choice words for the service department and then called my sales rep and got it ratcheted up a notch. Just waiting to hear back. If this isn't taken care of, it's not going to be a pretty scene.
 

·
Registered
Joined
·
12 Posts
Sorry to hear about your issues with your new truck. I went through similar situations with a Ford Dealer back in 2002-2005. Now I make sure I purchase a vehicle through a dealer who supplies loaners when the vehicle is in for service, warranty or non warranty.
 

·
Registered
Joined
·
3,988 Posts
I thought they were obligated to provide with replacement vehicle under warranty, especially if extended warranty was purchased thru ford.
 

·
Registered
Joined
·
3,988 Posts
PM "Father Patrick"(Blackstock) he may have the info to help you.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #19 ·
Update. After all of the sh!t that the service dept gave me, I decided to go the guy who actually sold me the truck. I pleaded my case, he said he'd take care of it, and within an hour I had my truck back (they paid for the repair) and they are paying for a rental when I bring her in for the 'full repair'.

It's amazing what some of these service departments get away with. Most people will bend over and take it from these guys if they didn't know better. If you don't stand up for yourself, they will walk all over you, and think it's perfectly legit.

So, from the stares I got from the service dept when I picked up my truck, I don't think I'm well liked there anymore (not that I care).

The bad news is that once they replace the wiring harness I will have to reinstall the starter/alarm. Since it took me 8 hours the first time, thats gonna suck.

Now I'm driving without the Edge as well. What a difference. Feels like I'm towing an anchor. Didn't truely appreciate the difference until I went back to stock.
 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top