Ford Tough - Home of Canadian Ford Truck Enthusiasts banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
1,901 Posts
Discussion Starter · #1 ·
Earlier this past summer, when I started using my AC in the truck, a smell would come from the vents and last for a minute or so. Then be gone. The smell was a manure, barn or stable smell. Some friends have said it smells like band aids...but I still say manure.

The truck is a 2013 with 8600 km...btw

A search online showed I was not alone with this problem. Some people are still fighting with dealers to not just deodorize the vents but to fix the problem. Others have had their evaporators replaced and that seems to fix it.

I finally took it to the dealer 2 weeks ago. After many trained "sniffers" took their turn smelling the air coming out my vents, they all agreed it smells...LOL
The job was sent to the Ford Hotline. And I was told I would hear from them in a few days.

They called last week and said Ford will be replacing my evaporator. Apparently the seams are seaping refrigerant and there is some kind of mould issue also.
I take my truck in next week to have my dash removed and evaporator installed. I am very pleased that it is getting fixed but a little worried how many rattles and squeaks I'll have after the dash reinstall...LOL...oh well.

So if anyone is getting a strange smell from your vents, check into this issue.
 

·
Administrator
Joined
·
4,742 Posts
Good heads up Dwayne, thanks for posting it up and not just ranting about the problem like some people have a tendency to do and then demanding a fix.

Hope your downtime is minimal as well as any post repair rattle and squeaks.
 

·
Registered
Joined
·
3,353 Posts
I try and shut the a/c off before i shut the vehicle off.

by shutting the car off with a/c cold. the warm air will condense. the water from the condensation will sit. by sitting it will cause mold to develop.

I noticed when i forgot to shut the a/c off I knew the next time i drove the car, as I could smell it a bit, but not for long.
 

·
Registered
Joined
·
18 Posts
I would be curious as to what the tech line told them. My FX4 has had the bandaid smell from day one and everyone refuses to do anything about it. It really stinks when you have the heat on... to the point of a headache. Do you mind posting what your work order said?
 

·
Premium Member
Joined
·
1,901 Posts
Discussion Starter · #5 ·
I would be curious as to what the tech line told them. My FX4 has had the bandaid smell from day one and everyone refuses to do anything about it. It really stinks when you have the heat on... to the point of a headache. Do you mind posting what your work order said?
I'll post all the info. Truck doesn't go in till the 29th though.
 

·
Registered
Joined
·
18 Posts
Great :)

I don't buy the a/c off before stopping the truck thing. I have 2 2013's, one being an XLT and the other being the FX4. The XLT never makes any odors and the a/c is honestly a lot better in it than the FX4's. Not to mention I have vehicles over 10 years old with working a/c and no stink in them lol. I guarantee my evaporator core is leaking too but getting someone to actually change it is another story.
 

·
Premium Member
Joined
·
1,901 Posts
Discussion Starter · #7 ·
Ok. Truck went in today. They had it from 7:45am to 5:20 pm. The drive home was odourless!!!! Other notes...the AC seems very cold now and I did not hear any squeaks or rattles from the reinstalled dash. I will keep this thread updated if the smell returns.


This is off the work order




Sent from my Motorola bag phone.
 

·
Administrator
Joined
·
4,742 Posts
Great news Dwayne, glad you got it taken care of with no issues, nice follow up.

Personal opinion, but I'm glad to see someone posting some good customer service feedback instead of the bitch and whine sessions we see sometimes.
 

·
Registered
Joined
·
18 Posts
Cool. Well hopefully somebody does that for me eventually. I won't chase it until I get lots of smell... which running defrost inevitably should bring on.
 

·
Premium Member
Joined
·
1,901 Posts
Discussion Starter · #10 ·
I agree Mike, the whining gets old fast.

Overall it was a very positive experience. I was called twice with updates on my truck throughout the day and they even had a rental ready for me, if the truck wasn't ready at closing time.

On another note, I had to pay for a 4-wheel alignment. My front tires were wearing funny, but I kept procrastinating and took it in 2 months past the 12 month 20,000 km coverage in which the alignment would have been free...an $80 lesson...my bad.
 

·
Super Moderator
Joined
·
1,604 Posts
Glad to hear it is fixed now Dwayne. One thing I noticed they put down on w.o. was about the clip " they " broke. Don't see that written down too often. ;)
 

·
Registered
Joined
·
903 Posts
both my 01 f150 and my 95 mecurey had the cow xxxx stink

I put a smooth cowel top on the f 150 last year and this year the smell was gone all summer

I presume it's because the cowel top is sealed now and the rain water can't get in to start growing mold in the heat-a/c box
 

·
Registered
Joined
·
71 Posts
We write that in our stories in order to explain why we're installing an unrelated part/component on warranty. The story gets posted to the final repair order/invoice, but it also serves as a means of communication between the tech and the front of house.

Glad this got sorted. Slow leaks from the evap core is incredibly common on the 1/2 tons! I average about 1 per month these days.
 
1 - 13 of 13 Posts
Top