Ford Tough - Home of Canadian Ford Truck Enthusiasts banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Okay.. another problem popped up on my 01 ford ranger ( 3.0L RWD).

Just a few days ago this started.. my O/D light keeps turning on and the truck shifts a little hard from 1st - 2nd gear.. and my worst concern is the cruise RPM. going 100km/h its at 3000 rpm.. way too high. so trying to pass people on the highway is pretty hard on the engine. pushing the O/D button doesn't do anything at highway speeds.

I recently finished college ( big debt) and got laid off from my job for a while.. so i am trying to read as much as i can and get some help from people online before i go into a shop, and piss my money away.

any help is appreciated.
Thanks.
 

·
Registered
Joined
·
2,401 Posts
if the o/d lamp is on/or flashing there is a trans failure,it should have stored codes that will point you in the right direction.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Yup the O/D off light is flashing.. but only after a few minutes of driving. After i shut the truck down it wont come on until i drive. i haven't been able to scan it.. looks like i should just take it into a shop.
 

·
Registered
Joined
·
9 Posts
You might have a solinoid problem, maybe not allowing pressure thru channel inside tranny. this will damage plates so get it seen too quick. Find out what tranny you have? Good luck.
 

·
Registered
Joined
·
9 Posts
Thank you everyone who messaged me. I checked the fluid level and yes it was way above the checked part of the dip stick so I drained a lot of fluid out. I also replaced the vss in the rear diff. Now all is good, also changed the diff oil & replaced engine oil. This F150 has only 116,+++klms from new, so I'll be driving it a long time. Thanks again.
 

·
Registered
Joined
·
56 Posts
Wow..congrats on finding a nice survivor with low klms and thanks for. Advice cause i love to tinker but im no mechanic even though i have a proper manual..
 
1 - 8 of 8 Posts
Top