Ford Tough - Home of Canadian Ford Truck Enthusiasts banner
1 - 9 of 9 Posts

· Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
so i woke up this mornin to find that everything outside has a layer of ice on it so i go start my truck to warm it up and melt the ice off the windshield. and i start driving and all of the sudden when i hit about 63 my steering wheel and truck started to shake. and it got worse when i went to 75 80km/h. so i pulled over into a parkin lot and checked the tires but there ok. and i just had my oil changed and tire rotation done at the 10000 mark a few days ago. so after i checked the tires i figured id keep going to see if it got worse and then it came back for a minut but you could barely tell that it was there and when got to my friendsz house and we started to drive around it wasnt there anymore. you guys think that something was just frozen? or is it something i should go see the dealer about??? thanks
 

· Registered
Joined
·
187 Posts
Discussion Starter · #3 ·
thanks man. i was really nervous there for a little bit lol. must have been that cus there was alot of snow on the rims and with that freezing rain probly set it off balance like you said. cus its gone now.
 

· Premium Member
Joined
·
7,683 Posts
thanks man. i was really nervous there for a little bit lol. must have been that cus there was alot of snow on the rims and with that freezing rain probly set it off balance like you said. cus its gone now.
I had that happen before to me, its weird filling.
The first thing I did was to check the Lug Nuts :icon_redface:
Than washed the rims an it was gone
:icon_lol:



 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top